Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda> Document Database Service> Guía del usuario> Resolución de problemas> Mensaje de error de conexión: no se pudo conectar al servidor
Actualización más reciente 2022-11-07 GMT+08:00

Mensaje de error de conexión: no se pudo conectar al servidor

Síntomas

Se notifica un error al ejecutar el siguiente comando para conectarse a una instancia DDS:

mongo --host 192.168.64.201 --port 8635 -u rwuser -p xxxxxxxxx --authenticationDatabase admin --ssl --sslCAFile /root/ca.crt --sslAllowInvalidHostnames

Mensaje de error:

MongoDB shell version v3.4.17
connecting to: mongodb://192.168.64.201:8635/
2019-09-19T09:45:48.168+0800 W NETWORK  [thread1] Failed to connect to 192.168.64.201:8635 after 5000ms milliseconds, giving up.
2019-09-19T09:45:48.168+0800 E QUERY    [thread1] Error: couldn't connect to server 192.168.64.201:8635, connection attempt failed :
connect@src/mongo/shell/mongo.js:240:13
@(connect):1:6
exception: connect failed

Causa posible

La política de grupo de seguridad no está configurada correctamente, lo que significa que las reglas de grupo de seguridad no permiten que el tráfico acceda a la instancia DDS.

Localización de fallas

Compruebe si la política de grupo de seguridad de la instancia DDS está configurada correctamente. Si la configuración de política del grupo de seguridad es incorrecta, no puede acceder a DDS desde fuera del grupo de seguridad.

Solución

Establezca la política de grupo de seguridad. Para obtener más información, consulte Configuración de un grupo de seguridad.