Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda> Document Database Service> Guía del usuario> Resolución de problemas> Mensaje de error de conexión: Error de autenticación
Actualización más reciente 2022-11-07 GMT+08:00

Mensaje de error de conexión: Error de autenticación

Síntomas

Se notifica un error al ejecutar el siguiente comando para conectarse a una instancia de base de datos DDS:

mongo --host 192.168.168.116 --port 8635 -u rwuser -p xxxxxxxxx --authenticationDatabase admin --ssl --sslCAFile /root/ca.crt --sslAllowInvalidHostnames

Mensaje de error:

MongoDB shell version v3.4.17
connecting to: mongodb://192.168.168.116:8635/
2019-09-19T09:39:24.306+0800 W NETWORK  [thread1] The server certificate does not match the host name. Hostname: 192.168.168.116 does not match CN: 172.16.2.65
MongoDB server version: 4.0.3
WARNING: shell and server versions do not match
2019-09-19T09:39:24.329+0800 E QUERY    [thread1] Error: Authentication failed. :
DB.prototype._authOrThrow@src/mongo/shell/db.js:1461:20
@(auth):6:1
@(auth):1:2
exception: login failed

Causa posible

Cuando se conecta a una instancia DDS, debe introducir la contraseña de administrador. Si la contraseña introducida es incorrecta, se muestra el mensaje "Error de autenticación".

Localización de fallas

Compruebe si la contraseña de administrador del comando para conectarse a la instancia DDS es correcta.

Solución

  • Introduzca la contraseña de administrador correcta.
  • Si olvida su contraseña, haga clic en la instancia de base de datos. En la página Basic Information mostrada, haga clic en Reset Password en el campo Administrator para restablecer la contraseña.
    Figura 1 Restablecimiento de una contraseña