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Centro de ayuda/ Identity and Access Management/ Preguntas frecuentes/ Gestión de grupos de usuarios y permisos/ ¿Por qué los permisos otorgados a un usuario no entran en vigor?

¿Por qué los permisos otorgados a un usuario no entran en vigor?

Actualización más reciente 2024-08-30 GMT+08:00

Síntoma

Las permisos que usted otorga a un usuario de IAM no surten efecto.

Resolución de problemas

  1. Causa: Se concedieron permisos incorrectos al grupo de usuarios al que pertenece el usuario.

    Solución: Solicite al administrador que modifique los permisos concedidos al grupo de usuarios al que pertenece el usuario IAM. Para obtener más detalles, consulte Modificación de permisos de grupo de usuario. Para obtener más detalles sobre los datos, consulte Permisos definidos por sistema.

  2. Causa: Acciones son denegadas por los permisos concedidos al usuario.

    Vea los permisos definidos por el sistema concedidos al usuario de IAM y compruebe si hay una declaración de política que deniegue la acción. Para obtener más detalles, consulte Sintaxis de política. Si el sistema definido no cumple con sus requisitos, cree una política personalizada para permitir la acción. Para obtener más detalles, consulte Creación de una política personalizada.

  3. Causa: El usuario IAM no se ha agregado al grupo de usuarios con permisos asignados.

    Solución: Agregue el usuario al grupo de usuarios de destino como administrador. Para obtener más detalles, consulte Adición de usuarios a un grupo de usuario.

  4. Causa: Para un servicio regional, al grupo de usuarios no se le asignan permisos en regiones específicas.

    Asignar permisos al grupo de usuarios en regiones específicas. Si solo ha asignado al usuario permisos para un proyecto predeterminado específico de región, el usuario no tiene permisos para los subproyectos. En este caso, asigne permisos para el subproyecto requerido. Para obtener más detalles, consulte Asignación de permisos a un grupo de usuarios.

  5. Causa: El usuario de IAM no se ha cambiado a la región en la que se ha autorizado al usuario a utilizar recursos en la nube.

    Recuérdele al usuario que cambie a la región donde el usuario está autorizado a usar recursos en la nube. Para obtener más detalles, consulte Cambio de regiones.

  6. Causa: Si el administrador ha concedido permisos de OBS al usuario, los permisos entrará en vigor entre 15 y 30 minutos después de la autorización.

    Compruebe los permisos después de 15 a 30 minutos e inténtelo de nuevo.

  7. Causa: La caché del navegador no se ha borrado durante mucho tiempo.

    Borre la caché del navegador e inténtelo de nuevo.

  8. Causa: El servicio (como OBS) proporciona un control de permisos separado.

    Conceda los permisos de usuario haciendo referencia a la documentación del servicio. Por ejemplo, consulte Introducción al control de permiso de OBS.

  9. Causa: Si ha concedido permisos a un usuario tanto en IAM como en Enterprise Management, es posible que los permisos para proyectos empresariales no surtan efecto. La autenticación IAM tiene prioridad sobre la autenticación de Enterprise Management. Si un usuario de IAM tiene el permiso ECS ReadOnlyAccess para todos los recursos y el proyecto de empresa A, el usuario puede ver todos los recursos de ECS.

    Modifique los permisos del usuario en la consola de IAM.

Preguntas frecuentes relacionadas

Síntoma: Ha concedido a un usuario de IAM solo los permisos necesarios, pero el usuario tiene más permisos.

Causas posibles:

  1. Los permisos necesarios otorgados al usuario de IAM tienen permisos de dependencia, que se asignan automáticamente para que los permisos necesarios puedan tener efecto para el usuario.
  2. Ha otorgado otros permisos al usuario de IAM en Gestión de proyecto empresarial. Si gestiona proyectos y usuarios mediante IAM, cancele los permisos configurados allí. Para obtener más información, consulte Eliminación de proyectos empresariales gestionados por un usuario.

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