¿Por qué los permisos otorgados a un usuario no entran en vigor?
Síntoma
Los permisos que concede a un usuario de IAM no han surtido efecto.
Resolución de problemas
- Los permisos concedidos al grupo de usuarios al que pertenece el usuario son incorrectos.
Solución: Modifique los permisos concedidos al grupo de usuarios al que pertenece el usuario de IAM como administrador. Para obtener más información, consulte Modificación de permisos de grupo de usuario o Permisos definidos por sistema.
- Algunos permisos concedidos al usuario niegan las acciones correspondientes a la operación correspondiente.
Vea los permisos definidos por el sistema otorgados al usuario de IAM y compruebe si hay una instrucción que deniegue la operación. Para obtener más información, consulte Sintaxis de política. Si los permisos definidos por el sistema no pueden cumplir sus requisitos, cree una política personalizada para permitir la operación. Para obtener más información, consulte Creación de una política personalizada.
- El usuario de IAM no se ha agregado al grupo al que el administrador ha asignado permisos.
Solución: Agregue el usuario al grupo de usuarios de destino como administrador. Para obtener más información, consulte Adición de usuarios a un grupo de usuario.
- Al usuario no se le asignan permisos para un servicio regional en la región correspondiente.
Asigne permisos para la región relevante al grupo al que pertenece el usuario. Si solo ha asignado al usuario permisos para un proyecto predeterminado específico de región, el usuario no tiene permisos para los subproyectos. En este caso, asigne permisos para el subproyecto requerido. Para obtener más información, consulte Asignación de permisos a un grupo de usuario.
- El usuario de IAM no ha cambiado a la región en la que se ha autorizado al usuario a utilizar recursos en la nube.
Recuérdele al usuario que cambie a la región donde el usuario está autorizado a usar recursos en la nube. Para obtener más información, consulte Cambio de regiones.
- Si el administrador ha concedido permisos OBS al usuario, los permisos surtirán efecto entre 15 y 30 minutos después de la autorización.
Compruebe los permisos después de 15 a 30 minutos e inténtelo de nuevo.
- La caché del navegador no se ha borrado durante mucho tiempo.
- El servicio (como OBS) proporciona un control de permisos independiente.
Otorgue los permisos de usuario haciendo referencia a la documentación del servicio. Por ejemplo, consulte Introducción al control de permiso de OBS.
- Si ha concedido permisos a un usuario tanto en IAM como en Enterprise Management, es posible que los permisos para proyectos de empresa no surtan efecto. La autenticación IAM tiene prioridad sobre la autenticación de Enterprise Management. Si un usuario de IAM tiene el permiso ECS ReadOnlyAccess para todos los recursos y el proyecto de empresa A, el usuario puede ver todos los recursos de ECS.
Modifique los permisos del usuario en la consola de IAM.
Preguntas frecuentes relacionadas
Síntoma: Ha concedido a un usuario de IAM solo los permisos necesarios, pero el usuario tiene más permisos.
Causas posibles:
- Los permisos necesarios otorgados al usuario de IAM tienen permisos de dependencia, que se asignan automáticamente para que los permisos necesarios puedan tener efecto para el usuario.
- Ha otorgado otros permisos al usuario de IAM en Gestión de proyecto empresarial. Si gestiona proyectos y usuarios mediante IAM, cancele los permisos configurados allí. Para obtener más información, consulte Eliminación de proyectos empresariales gestionados por un usuario.
Gestión de grupos de usuarios y permisos Preguntas frecuentes
- ¿Por qué no están disponibles los permisos para un servicio en la nube?
- ¿Cómo puedo otorgar permisos de servicio en la nube específicos para la región EU-Dublin a los usuarios de IAM?
- ¿Por qué los permisos otorgados a un usuario no entran en vigor?
- ¿Cómo puedo conceder a un usuario de IAM permisos para realizar pedidos pero no permitir el pago de pedidos?
Comentarios
¿Le pareció útil esta página?
Deje algún comentariomore