Compute
Elastic Cloud Server
Huawei Cloud Flexus
Bare Metal Server
Auto Scaling
Image Management Service
Dedicated Host
FunctionGraph
Cloud Phone Host
Huawei Cloud EulerOS
Networking
Virtual Private Cloud
Elastic IP
Elastic Load Balance
NAT Gateway
Direct Connect
Virtual Private Network
VPC Endpoint
Cloud Connect
Enterprise Router
Enterprise Switch
Global Accelerator
Management & Governance
Cloud Eye
Identity and Access Management
Cloud Trace Service
Resource Formation Service
Tag Management Service
Log Tank Service
Config
OneAccess
Resource Access Manager
Simple Message Notification
Application Performance Management
Application Operations Management
Organizations
Optimization Advisor
IAM Identity Center
Cloud Operations Center
Resource Governance Center
Migration
Server Migration Service
Object Storage Migration Service
Cloud Data Migration
Migration Center
Cloud Ecosystem
KooGallery
Partner Center
User Support
My Account
Billing Center
Cost Center
Resource Center
Enterprise Management
Service Tickets
HUAWEI CLOUD (International) FAQs
ICP Filing
Support Plans
My Credentials
Customer Operation Capabilities
Partner Support Plans
Professional Services
Analytics
MapReduce Service
Data Lake Insight
CloudTable Service
Cloud Search Service
Data Lake Visualization
Data Ingestion Service
GaussDB(DWS)
DataArts Studio
Data Lake Factory
DataArts Lake Formation
IoT
IoT Device Access
Others
Product Pricing Details
System Permissions
Console Quick Start
Common FAQs
Instructions for Associating with a HUAWEI CLOUD Partner
Message Center
Security & Compliance
Security Technologies and Applications
Web Application Firewall
Host Security Service
Cloud Firewall
SecMaster
Anti-DDoS Service
Data Encryption Workshop
Database Security Service
Cloud Bastion Host
Data Security Center
Cloud Certificate Manager
Edge Security
Situation Awareness
Managed Threat Detection
Blockchain
Blockchain Service
Web3 Node Engine Service
Media Services
Media Processing Center
Video On Demand
Live
SparkRTC
MetaStudio
Storage
Object Storage Service
Elastic Volume Service
Cloud Backup and Recovery
Storage Disaster Recovery Service
Scalable File Service Turbo
Scalable File Service
Volume Backup Service
Cloud Server Backup Service
Data Express Service
Dedicated Distributed Storage Service
Containers
Cloud Container Engine
SoftWare Repository for Container
Application Service Mesh
Ubiquitous Cloud Native Service
Cloud Container Instance
Databases
Relational Database Service
Document Database Service
Data Admin Service
Data Replication Service
GeminiDB
GaussDB
Distributed Database Middleware
Database and Application Migration UGO
TaurusDB
Middleware
Distributed Cache Service
API Gateway
Distributed Message Service for Kafka
Distributed Message Service for RabbitMQ
Distributed Message Service for RocketMQ
Cloud Service Engine
Multi-Site High Availability Service
EventGrid
Dedicated Cloud
Dedicated Computing Cluster
Business Applications
Workspace
ROMA Connect
Message & SMS
Domain Name Service
Edge Data Center Management
Meeting
AI
Face Recognition Service
Graph Engine Service
Content Moderation
Image Recognition
Optical Character Recognition
ModelArts
ImageSearch
Conversational Bot Service
Speech Interaction Service
Huawei HiLens
Video Intelligent Analysis Service
Developer Tools
SDK Developer Guide
API Request Signing Guide
Terraform
Koo Command Line Interface
Content Delivery & Edge Computing
Content Delivery Network
Intelligent EdgeFabric
CloudPond
Intelligent EdgeCloud
Solutions
SAP Cloud
High Performance Computing
Developer Services
ServiceStage
CodeArts
CodeArts PerfTest
CodeArts Req
CodeArts Pipeline
CodeArts Build
CodeArts Deploy
CodeArts Artifact
CodeArts TestPlan
CodeArts Check
CodeArts Repo
Cloud Application Engine
MacroVerse aPaaS
KooMessage
KooPhone
KooDrive
Help Center/ Scalable File Service/ Troubleshooting/ Mounting a File System Times Out

Mounting a File System Times Out

Updated on 2024-06-27 GMT+08:00

Symptom

When a file system is mounted to a cloud server using the mount command, message timed out is returned.

Possible Causes

  • Cause 1: The network is not stable.
  • Cause 2: The network connection is abnormal.
  • Cause 3: A VPC endpoint is not purchased.
  • Cause 4: The DNS configuration of the server is incorrect. As a result, the domain name of the file system cannot be resolved, and the mounting fails. This issue will not occur on SFS Turbo file systems.
  • Cause 5: The server that mounts the file system runs Ubuntu18 or later.

Fault Diagnosis

Rectify network faults and mount the file system again.

Solution

  • Cause 1 and Cause 2: The network is not stable or the network connection is abnormal.

    Remount the file system after the network issue is addressed.

    • If the mount is successful, no further action is required.
    • If the problem persists, see the solution for cause 3.
  • Cause 3: A VPC endpoint is not purchased.

    Buy a VPC endpoint and then remount the file system. For details, see Configure a VPC Endpoint.

    • If the mount is successful, no further action is required.
    • If the problem persists, see the solution for cause 4.
  • Cause 4: The DNS configuration of the server is incorrect. As a result, the domain name of the file system cannot be resolved, and the mounting fails.
    1. Check the DNS configuration of the tenant and run the cat /etc/resolv.conf command.
      • If the DNS has not been configured, configure it by referring to Configuring DNS.
      • If the DNS has been configured, run the following command to check whether the configuration is correct:

        nslookup File system domain name

        If the resolved IP address is in network segment 100, the DNS configuration is correct. If the IP address is in another network segment, the DNS configuration is incorrect. In this case, go to 2.

    2. Modify the /etc/resolv.conf configuration file to configure the correct tenant DNS. Specifically, run vi /etc/resolv.conf to edit the /etc/resolv.conf file. Add the DNS server IP address above the existing nameserver information. To obtain DNS server IP addresses, see What Are Private DNS Servers and What Are Their Addresses?
      Figure 1 Configuring DNS
      The format is as follows:
      nameserver 100.125.1.250
      • If the configuration succeeds, go to 3.
      • If the configuration fails, run the lsattr /etc/resolv.conf command. If the information shown in Figure 2 is displayed, the file is locked.
        Figure 2 A locked file

        Run the chattr -i/etc/resolv.conf command to unlock the file. Then, re-configure the DNS and go to 3.

    3. Press Esc, input :wq, and press Enter to save the changes and exit the vi editor.
    4. Set the correct tenant DNS for the subnet of the VPC where the server belongs. By default, the server inherits the DNS configuration of the VPC every time the server restarts. Changing only the server DNS configuration does not resolve the issue completely.

    5. (Optional) Restart the server.
    6. Run the mount command again.
      • If the mount is successful, no further action is required.
      • If the problem persists, see the solution for cause 5.
  • Cause 5: The server that mounts the file system runs Ubuntu18 or later.
    1. Reconfigure DNS by referring to Configuring DNS.
    2. Check whether the server running Ubuntu18 or later was created from a private image.
      • If yes, go to 4.
      • If no, go to 3.
    3. Convert the public image server to a private image server.
      1. Create a private image for the server by referring to section "Creating an Image" in the Elastic Cloud Server User Guide.
      2. Use the private image obtained in 3.a to create a server or change the server OS to the created private image by referring to section "Changing the OS" in the Elastic Cloud Server User Guide.
    4. Log in to the server and remount the file system.

We use cookies to improve our site and your experience. By continuing to browse our site you accept our cookie policy. Find out more

Feedback

Feedback

Feedback

0/500

Selected Content

Submit selected content with the feedback