Mounting a File System Fails
Symptom
When a file system is mounted to a server using the mount command, message access denied is displayed on the server.
When a general purpose file system is mounted to a server using the mount command and message Connection refused is displayed on the server, see cause 3 for more information.
Possible Causes
- Cause 1: The file system has been deleted.
- Cause 2: The server and the mounted file system are not in the same VPC.
- Cause 3: No VPC endpoint is purchased.
- Cause 4: The new route table does not contain the corresponding VPC endpoint.
- Cause 5: The mount point in the mount command is incorrect.
- Cause 6: The IP address used for accessing SFS is a virtual IP address.
- Cause 7: The DNS used for accessing the file system is incorrect.
- Cause 8: A CIFS file system is mounted to Linux servers.
- Cause 9: The subdirectory used for mounting is not found.
- Cause 10: The current PowerShell version is incompatible.
Fault Diagnosis
Take troubleshooting measures based on possible causes.
Solution
- Cause 1: The file system has been deleted.
- Cause 2: The server and the mounted file system are not in the same VPC.
- Cause 3: No VPC endpoint is purchased.
Buy a VPC endpoint and then remount the file system. For details, see Configure a VPC Endpoint.
- If the remount is successful, no further action is required.
- If the problem persists, see the solution for cause 4.
- Cause 4: The new route table does not contain the corresponding VPC endpoint.
When a new route table is added, you need to buy a new VPC endpoint and select the new route table for the VPC endpoint.
- If the remount is successful, no further action is required.
- If the problem persists, see the solution for cause 5.
- Cause 5: The mount point in the mount command is incorrect.
- Log in to the management console and check whether the mount point is the same as the one in the mount command.
- If the mount point in the mount command is incorrectly entered, correct it and run the command again.
- Cause 6: The IP address used for accessing SFS is a virtual IP address.
Log in to the server and run the ping command and use the server IP address to access SFS. Check whether the service is reachable. See Figure 1.
- If yes, the network problem has been resolved. Check other possible causes.
- If no, the server virtual IP address is unable to access SFS due to the network problem. Use the private IP address and run the ping command to access SFS and check whether the service is reachable.
- Cause 7: The DNS used for accessing the file system is incorrect.
Run the following command to check whether the DNS is correct:
nslookup File system domain name
Check whether the resolved IP address is in segment 100.
- If yes, the DNS configuration is correct. Check other possible causes.
- If no, the DNS configuration is incorrect. Reconfigure DNS by referring to Configuring DNS.
- Cause 8: A CIFS file system is mounted to Linux servers.
CIFS file systems cannot be mounted to Linux ECSs. Mount the CIFS file system to Windows servers.
- Cause 9: The subdirectory used for mounting is not found.
Mount the file system to the root directory. Then create a subdirectory, unmount the mounted file system, and mount the file system to the created subdirectory.
- Cause 10: The current PowerShell version is incompatible.
If the file system fails to be mounted using PowerShell, the PowerShell version may be incompatible. You are advised to mount the file system using command.
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