Help Center/ Scalable File Service/ Troubleshooting/ Mounting a General-Purpose File System Failed
Updated on 2025-12-10 GMT+08:00

Mounting a General-Purpose File System Failed

Symptom

When a general-purpose file system was mounted to a server using the mount command, message access denied was displayed on the server.

When a general-purpose file system was mounted to a server using the mount command and message Connection refused was displayed on the server, see cause 3 for more information.

Possible Causes

  • Cause 1: The general-purpose file system has been deleted.
  • Cause 2: The server and the general-purpose file system are not in the same VPC.
  • Cause 3: No VPC endpoint is purchased.
  • Cause 4: The new route table does not contain the corresponding VPC endpoint.
  • Cause 5: The mount point specified in the mount command is incorrect.
  • Cause 6: The IP address used for accessing SFS is a virtual IP address.
  • Cause 7: The DNS configuration on the server is incorrect.
  • Cause 8: The subdirectory used for mounting is not found.

Fault Diagnosis

Take troubleshooting measures based on possible causes.

Solution

  • Cause 1: The general-purpose file system has been deleted.
    Log in to the SFS console and check whether the file system is deleted.
    • If yes, create a general-purpose file system or select an existing one to mount. Ensure that the server and the file system are in the same VPC.
    • If no, go to Cause 2.
  • Cause 2: The server and the general-purpose file system are not in the same VPC.
    Log in to the console and check whether the server and the file system are in the same VPC.
    • If yes, go to Cause 3.
    • If no, select a general-purpose file system that is in the same VPC as the server.
  • Cause 3: No VPC endpoint is purchased.

    Buy a VPC endpoint and then remount the file system. For details, see Configuring a VPC Endpoint.

    • If the remount is successful, no further action is required.
    • If the problem persists, see the solution for cause 4.
  • Cause 4: The new route table does not contain the corresponding VPC endpoint.

    When a new route table is added, you need to buy a new VPC endpoint and select the new route table for the VPC endpoint.

    • If the remount is successful, no further action is required.
    • If the problem persists, see the solution for cause 5.
  • Cause 5: The mount point specified in the mount command is incorrect.
    1. Log in to the console and check whether the mount point specified in the mount command is the same as that shown on the console.
    2. If the mount point specified in the mount command is incorrect, correct it and run the command again.
  • Cause 6: The IP address used for accessing SFS is a virtual IP address.

    Log in to the server and use the ping command and the server's virtual IP address to access SFS. Check whether the service is reachable.

    • If yes, the network is connected. Check other possible causes.
    • If no, the network is disconnected. Use the server's private IP address and the ping command to access SFS and check whether the service is reachable.
      Figure 1 Running the ping command to access SFS
  • Cause 7: The DNS configuration on the server is incorrect.

    Check whether the DNS configuration is correct.

    nslookup <domain-name-of-the-general-purpose-file-system>

    Check whether the resolved IP address is in the 100.x.x.x network range.

    • If yes, the DNS configuration is correct. Check other possible causes.
    • If no, the DNS configuration is incorrect. Reconfigure the DNS by referring to Configuring DNS.
  • Cause 8: The subdirectory used for mounting is not found.

    Mount the root directory of the general-purpose file system. Then, create a subdirectory, unmount the file system, and mount the file system using the created subdirectory.