Updated on 2024-02-27 GMT+08:00

How Do I Fix an Abnormal Agent?

Your agent is probably abnormal if it is in Not installed or Offline state. Agent statuses and their meaning are as follows:

  • Not installed: No agent has been installed on the server, or the agent has been installed but not started.
  • Offline: The communication between the agent and the server is abnormal. The agent on the server has been deleted, or a non-HUAWEI CLOUD server is offline.
  • Online: The agent on the server is running properly.

Possible Causes

  • The network is faulty.

    The agent or the cloud protection center is abnormal. For example, the NIC is faulty, the IP address changes, or the bandwidth is low.

  • The agent process is abnormal.
  • It takes 3 to 5 minutes for the console to update the agent status after agent installation.

Solution

  1. Fix network problems (if any).

    Ensure that the outbound configurations of the security group of your server allow access to port 443 in the 100.125.0.0/16 network segment.

    After the network recovers,
    • If the agent status is Online, no further action is required.
    • If the agent status is Not installed or Offline, go to Step 2.

  2. Log in to the server and restart the agent. The agent status Not installed or Offline indicates that the agent process is probably abnormal.

    • Windows OS

      Log in to the server as administrator and restart the client.

      Figure 1 Restarting Windows agent
    • Linux OS

      Run the following command in the CLI as user root to restart the agent:

      service hostguard restart

      If the following information is displayed, the restart is successful: If no command output is displayed, uninstall the Agent, then install the Agent again.
      root@HSS-Ubuntu32:~#service hostguard restart
      Stopping Hostguard...
      Hostguard stopped
      Hostguard restarting...
      Hostguard is running

    After the process is restarted, wait for about 2 minutes.

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