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更新时间:2024-09-24 GMT+08:00
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Agent状态异常应如何处理?

Agent状态主要分为以下三种,如果Agent的运行状态为“未安装”或者“离线”时,表示Agent与服务器间通信异常。

  • 未安装:主机从未安装Agent,或Agent已安装但未成功启动。
  • 离线:Agent与服务器通信异常,主机中的Agent已被删除,或非华为云主机离线。
  • 在线:主机内的Agent运行正常。

可能的原因

  • 控制台Agent状态未更新。

    安装Agent后,不会立即生效,需要等待5-10分钟左右控制台才会刷新。

  • 操作系统不支持。

    HSS目前支持的操作系统请参见HSS支持的操作系统及版本

  • 网络故障。

    主机中的Agent和云端防护中心出现异常,如网卡故障、IP地址异变及带宽较低。

  • 主机内存不足。
  • Agent进程异常。

处理方法

  1. 在主机上安装Agent成功已超过10分钟,控制台Agent状态仍显示“离线”

    • 是:请执行2
    • 否:请您耐心等待Agent上线,无需执行后续操作。安装Agent成功后,不会立即生效,需要等待5-10分钟左右控制台才会刷新状态。

  2. 主机的操作系统是否在HSS支持的操作系统及版本范围内。

    • 是:请执行3
    • 否:企业主机安全的Agent无法正常安装和运行在您的主机上,请升级为企业主机安全支持的操作系统后再尝试安装Agent。

  3. 主机网络是否正常。

    • 是:请执行4
    • 否:请确保您的主机所属安全组出方向设置允许访问100.125.0.0/16网段的10180端口,且主机能正常访问网络。待主机能正常访问网络后,再查看Agent状态。

  4. 主机剩余可用内存是否大于300MB。

    • 是:请执行5
    • 否:主机内存不足将导致Agent离线,请扩充内存容量,容量扩充完成后,Agent将恢复上线。

  5. Agent进程异常,需要重启Agent。

    • Windows操作系统
      1. 以管理员administrator权限登录主机。
      2. 打开“任务管理器”
      3. “服务”页签选中“HostGuard”
      4. 单击鼠标右键,选择“重新启动”,完成重启Agent。
    • Linux操作系统

      请以root用户在命令行终端执行以下命令,完成重启Agent。

      /etc/init.d/hostguard restart

      如果回显以下信息,则表示重启成功。
      root@HSS-Ubuntu32:~#/etc/init.d/hostguard  restart
      Stopping Hostguard...
      Hostguard stopped
      Hostguard restarting...
      Hostguard is running

    重启进程后等待2-3分钟:

    • 如果Agent状态为“在线”,则故障清除。
    • 如果Agent状态仍为“未安装”或者“离线”,请卸载Agent,再重新安装Agent。

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