Agent状态异常应如何处理?
Agent状态主要分为以下三种,如果Agent的运行状态为“未安装”或者“离线”时,表示Agent状态异常。
- 未安装:主机从未安装Agent,或Agent已安装但未成功启动。
- 离线:Agent与服务器通信异常,主机中的Agent已被删除,或非华为云主机离线。
- 在线:主机内的Agent运行正常。
可能的原因
- 控制台Agent状态未更新。
- 操作系统不支持。
HSS目前支持的操作系统请参见HSS支持的操作系统及版本。
- 网络故障。
- 主机内存不足。
- Agent进程异常。
处理方法
- 为主机安装Agent已超过10分钟,控制台Agent状态显示“离线”或者“未安装”。
- 是:请执行2。
- 否:请您耐心等待Agent上线,无需执行后续操作。安装Agent成功后,不会立即生效,需要等待5-10分钟左右控制台才会刷新状态。
- 请确认主机的操作系统是否在HSS支持的操作系统及版本范围内。
- 是:请执行3。
- 否:企业主机安全的Agent无法正常安装和运行在您的主机上,请升级为企业主机安全支持的操作系统后再尝试安装Agent。
- 请确认主机是否可正常访问网络。
- 是:主机可正常访问网络,请执行4。
- 否:请确保您的主机能正常访问网络后,再前往HSS控制台查看Agent状态。
- 请确认主机是否满足以下条件:
- “华东二”、“西南-贵阳一”区域
请参考验证网络是否打通成功,确认主机所属VPC的是否存在名称为“com.myhuaweicloud.xxx.hss-agent”的终端节点。该终端节点用于主机和HSS服务端通信。
- 除“华东二”、“西南-贵阳一”以外的其他区域
请确认主机所属安全组出方向是否允许访问100.125.0.0/16网段的10180端口。
- “华东二”、“西南-贵阳一”区域
- 请确认待安装Agent的磁盘容量是否大于300MB。
对于Linux主机,Agent默认安装在/usr/local/hostguard/路径下,您需要确认该路径所在磁盘分区剩余容量是否大于300MB。对于Windows主机,Agent默认安装C:\Program Files\HostGuard路径下,您需要确认C盘剩余容量是否大于300MB。
- 是:请执行6。
- 否:主机内存不足将导致Agent离线,请扩充内存容量,容量扩充完成后,Agent将恢复上线。
- Agent进程异常,请按如下操作重启Agent。
- Windows操作系统
- 以管理员administrator权限登录主机。
- 打开“任务管理器”。
- 在“服务”页签选中“HostGuard”。
- 单击鼠标右键,选择“重新启动”,完成重启Agent。
- Linux操作系统
请以root用户在命令行终端执行以下命令,完成重启Agent。
/etc/init.d/hostguard restart
如果回显以下信息,则表示重启成功。root@HSS-Ubuntu32:~#/etc/init.d/hostguard restart Stopping Hostguard... Hostguard stopped Hostguard restarting... Hostguard is running
重启进程后等待2-3分钟:
- 如果Agent状态为“在线”,则故障清除。
- 如果Agent状态仍为“未安装”或者“离线”,请卸载Agent,再重新安装Agent。
- 卸载Agent请参见如何卸载Agent?。
卸载操作执行完成后,请等待5~10分钟,确认服务器展示在HSS控制台的
页面后,再执行安装Agent操作。 - 安装Agent请参见为主机安装Agent。
“华东二”、“西南-贵阳一”区域,通过命令行为华为云主机安装Agent时,由于此前已经打通过服务器网络,因此在“选择打通网络服务器”步骤,无需再选择服务器,直接执行下一步即可。
- 卸载Agent请参见如何卸载Agent?。
- Windows操作系统