Help Center> Cloud Bastion Host> FAQs> Troubleshooting> Maintenance Issues> Why Does File Upload to or Download from a Managed Host Fail?

Why Does File Upload to or Download from a Managed Host Fail?

File Upload or Download Failures During Web-Based O&M

Symptoms

  • When you attempt to transfer a Host File to Personal Netdisk, an error message is displayed indicating that the download failed.
  • You cannot upload files and error the message "/3.0/h5FileService/upload-403: Service error. Please try again later." is displayed.
  • When you attempt to upload a file from a local host to Netdisk, or Personal Netdisk, the system displays a message indicating that the Personal Netdisk space is insufficient.
  • You cannot upload or download large files.

Possible Causes

  • Cause 1: The Personal Netdisk space cannot be automatically cleared. The Personal Netdisk space is insufficient, or the available system storage space is insufficient.
  • Cause 2: The browser cache space is insufficient.
  • Cause 3: Uploading or downloading large files takes a long time, and the web login connection times out. As a result, uploading or downloading large files fails.
  • Cause 4: The CBH system version is not the latest one.
  • Cause 5: The file is not compressed.

Solutions

Solution to cause 1

Solution to cause 2
  • Clear the browser cache and upload the file again.

Solution to cause 3

  • Split a large file into several small files of about one GB and upload or download the small files in batches.
  • During the upload or download process, check the upload or download page regularly to avoid system timeout.
  • Contact the administrator to change the web login timeout interval. For details, see Web Login Configuration.
  • Contact the administrator to set the personal netdisk capacity by referring to How Do I Set the Personal Netdisk Capacity?
  • If the size of the file to be uploaded or downloaded is greater than the remaining Data Partition, contact the administrator to clear the system space or expand the CBH instance capacity.

Solution to cause 4

Upgrade the CBH system version by referring to Upgrading the Version of a CBH System.

Solution to cause 5

In CBH, file folders must be compressed into packages for downloading.

File Upload or Download Failures During SSH Client O&M

Symptoms

If you use the Xshell client to log in to the hosts configured with the SSH protocol, the Xftp client cannot be called to transfer files.

Possible Causes

File transfer and transferred file auditing are disabled by the CBH system for O&M using an SSH client.

Solutions

  • Configure the FTP/SFTP protocol for the host with the same IP address and use the FTP/SFTP client to transfer files.

    For example, you can configure the SFTP for the host and assign access control permissions for the host. Then, you can directly log in to the host on the Xftp client to upload or download files.

  • Log in to the host configured with the SSH protocol using a web browser to upload and download files.

For more information about file transfer in web-based O&M, see How Do I Upload or Download Files During Web-Based O&M?

For details about how to transfer files of host configured with the SSH protocol, see How Do I Use the FTP/SFTP Client to Transfer Files to and from an SSH Host?

If the problem persists, click Service Tickets in the upper right corner of the management console and submit a service ticket.