云堡垒机 CBH
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登录资源故障
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运维故障
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通过Web浏览器登录资源,报Code:T_514错误怎么办?
问题现象
通过Web浏览器登录资源,会话页面载入失败,提示“由于服务器长时间无响应,连接已断开,请检查您的网络并重试(Code:T_514)”。
可能原因
- 云堡垒机系统与资源服务器之间网络连接不稳定,导致连接断开。
- 云堡垒机系统到资源服务器的网络被设置拦截,导致网络不通畅。
- 资源服务器异常无响应,导致连接断开。
排查思路
以下排查思路按照“Code:T_514”问题的状态进行逐层细化,您可以根据实际情况选择对应的分支进行排查。
图1 排查思路
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检查网络连接情况
登录云堡垒机系统,网络诊断ping连通性测试,验证云堡垒机与资源服务器之间的网络连接是否正常。
- 网络连接通畅,则网络不稳定导致连接无响应。
重启相应资源服务器,重新开机后网络恢复正常。若重启主机不能解决,建议再排查云服务器故障/卡顿。
- 网络连接不通,则CBH系统到资源服务器有网络限制,请参考下述方案依次排查。
- 请先确认当前用户网络环境,是否为内网用户,以及用户访问权限是否受限。
例如因华为云内网用户,无法访问公网资源,即未授权的内网用户不能登录运维资源,需先申请外网访问权限或申请Websocket权限。
- 检查CBH系统环境是否配置合理
- 检查主机实例环境是否合理配置
- 检查主机资源是否配置安全加固措施
- 请先确认当前用户网络环境,是否为内网用户,以及用户访问权限是否受限。
检查CBH系统环境是否配置合理
- 登录云堡垒机系统,检查纳管资源IP地址、端口等是否设置正确。
- 检查资源关联访问控制策略,是否设置IP限制。修改访问控制策略,解除对用户“来源IP”的限制。
- 检查云堡垒机实例关联的安全组,排查安全组的端口配置是否合理。建议按照CBH推荐端口,重新配置CBH安全组。
用户若通过Web浏览器方式登录资源,请手动添加安全组规则TCP协议443入方向。
- 检查云堡垒机所在内网关联的网络ACL ,排查ACL规则配置是否合理。
解除云堡垒机IP地址的访问限制,以及在“目的地址”中添加资源IP地址,允许云堡垒机访问资源。
- 重新设置后,尝试重新通过CBH系统登录资源。
检查主机实例环境是否合理配置
- 管理员登录主机实例管理控制台。
- 检查主机资源是否与CBH实例在同一区域同一VPC环境下,CBH仅支持直接访问同一区域同一VPC下资源。
- 检查主机实例关联的安全组规则,排查安全组规则配置是否合理。
解除对CBH的IP地址的访问限制,在源地址中添加CBH的IP地址,允许CBH访问资源。
- 重新设置后,尝试重新通过CBH系统登录资源。
检查主机资源是否配置安全加固措施
- 管理员直接登录主机资源。
- 检查主机登录方式及登录安全加固措施,建议从以下几个方面排查:
- 从以下几个方面分别排查,解除主机安全加固对云堡垒机的登录限制。
- 解除安全加固的限制后,尝试重新通过CBH系统登录资源。
如果通过上述排查,仍然无法解决问题,请单击管理控制台右上方的“工单”,填写工单信息反馈问题现象,联系技术支持。
父主题: 登录资源故障