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更新时间:2023-11-20 GMT+08:00
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在控制台查看不到日志怎么办?

问题描述

在AOM控制台查不到日志。

可能原因

  • 未安装ICAgent日志采集工具。
  • 采集路径配置错误。
  • AOM控制台上的“日志采集开关”未开启。
  • AOM控制台上的“超额继续采集日志”开关未开启。
  • 当前账号欠费,故采集器停止采集。
  • 日志流写入速率和单行日志长度超出使用限制。

解决办法

  • 安装ICAgent,方法如下:
    1. 在左侧导航栏中选择“配置管理 > Agent管理”。
    2. 选择对应集群,单击“安装ICAgent”,然后在弹出的提示框单击“确定”。

      等待“ICAgent状态”列显示为“运行”,则表示ICAgent安装成功。

  • 采集路径如果配置的是目录,示例:/var/logs/,则只采集目录下后缀为“.log”、“.trace”和“.out”的文件;如果配置的是文件名,则直接采集对应文件,只支持文本类型的文件。更多关于日志采集路径的说明请参见:配置日志采集路径
  • 登录AOM控制台,在左侧导航栏中选择“配置管理 > 日志配置”,在“配置中心 > 采集开关”页签,将“日志采集开关”置于“开启”状态。
  • 日志的计费依据为日志使用量,包括日志读写、日志索引和日志存储。超过免费额度后,将无法再进行日志读写和索引,同时也不再产生日志读写和索引费用。此时需要打开“超额继续采集日志”开关。方法如下:

    登录AOM控制台,在左侧导航栏中选择“配置管理 > 日志配置”,在“配置中心 > 配额设置”页签,将“超额继续采集日志”开关置于“开启”状态。

  • 客户欠费后,为防止相关资源不被停止或者释放,需要客户及时进行充值,详细说明请参见:欠费还款
  • 更换Chrome或Firefox浏览器查询日志。
  • 若以上解决办法无法解决您的问题,请提交工单寻求工程师的帮助。
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