更新时间:2023-11-20 GMT+08:00
在控制台查看不到日志怎么办?
问题描述
在AOM控制台查不到日志。
可能原因
- 未安装ICAgent日志采集工具。
- 采集路径配置错误。
- AOM控制台上的“日志采集开关”未开启。
- AOM控制台上的“超额继续采集日志”开关未开启。
- 当前账号欠费,故采集器停止采集。
- 日志流写入速率和单行日志长度超出使用限制。
解决办法
- 安装ICAgent,方法如下:
- 采集路径如果配置的是目录,示例:/var/logs/,则只采集目录下后缀为“.log”、“.trace”和“.out”的文件;如果配置的是文件名,则直接采集对应文件,只支持文本类型的文件。更多关于日志采集路径的说明请参见:配置日志采集路径。
- 登录AOM控制台,在左侧导航栏中选择“配置管理 > 日志配置”,在“配置中心 > 采集开关”页签,将“日志采集开关”置于“开启”状态。
- 日志的计费依据为日志使用量,包括日志读写、日志索引和日志存储。超过免费额度后,将无法再进行日志读写和索引,同时也不再产生日志读写和索引费用。此时需要打开“超额继续采集日志”开关。方法如下:
登录AOM控制台,在左侧导航栏中选择“配置管理 > 日志配置”,在“配置中心 > 配额设置”页签,将“超额继续采集日志”开关置于“开启”状态。
- 客户欠费后,为防止相关资源不被停止或者释放,需要客户及时进行充值,详细说明请参见:欠费还款。
- 更换Chrome或Firefox浏览器查询日志。
- 若以上解决办法无法解决您的问题,请提交工单寻求工程师的帮助。
父主题: 常见使用问题
常见使用问题 所有常见问题
- 没有消息通知服务的访问权限?
- 资源运行异常怎么办?
- 如何设置全屏模式在线时长?
- 日志配额已达到90%或已满怎么办?
- 如何获取AK/SK?
- 如何查询服务不可用时间?
- AOM告警规则状态为什么显示“数据不足”?
- 正常状态的工作负载,AOM界面显示异常是什么原因?
- 如何创建委托apm_admin_trust?
- 如何通过创建委托获取AK/SK?
- 日志费用说明
- 在控制台查看不到日志怎么办?
- 如何处理界面“ICAgent状态”为“离线”的问题?
- 安装了ICAgent,但是监控不到主机是什么原因?
- 安装ICAgent过程中,系统提示“no crontab for root”是什么原因?
- AOM配置日志转储时无法选中obs桶是什么原因?
- Grafana无法展示内容是什么原因?
more