ALM-24003 Flume Client连接中断(2.x及以前版本)
告警解释
告警模块对Flume Server的连接端口状态进行监控。当Flume Client连接到Flume Server的某个端口,Client端连续3分钟未与Server端连接时,系统产生此告警。
当Flume Server收到Flume Client连接消息,告警恢复。
告警属性
告警ID |
告警级别 |
可自动清除 |
---|---|---|
24003 |
严重 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
ClientIP |
Flume客户端IP地址。 |
ServerIP |
Flume服务端IP地址。 |
ServerPort |
Flume服务端端口。 |
对系统的影响
产生告警的Flume Client无法与Flume Server端进行通信,Flume Client端的数据无法传输到Flume Server端。
可能原因
- Flume Client端与Flume Server端网络故障。
- Flume Client端进程故障。
- Flume Client端配置错误。
处理步骤
- 检查Flume Client与Flume Server的网络状况。
- 检查Flume Client端进程故障。
- 检查Flume Client端的配置。
- 登录告警定位参数中描述的Flume ClientIP所在主机,执行以下命令切换root用户。
- 执行cd Flume安装目录/fusioninsight-flume-1.6.0/conf/命令,进入Flume的配置目录。
- 执行cat properties.properties命令,查看当前的Flume Client配置文件。
- 根据Flume Agent的配置说明检查“properties.properties”的配置是否有误。
- 修改“properties.properties”配置文件。
- 查看告警列表中,该告警是否已清除。
- 是,处理完毕。
- 否,执行4。
- 收集故障信息。
- 在MRS Manager界面,单击“系统设置 > 日志导出”。
- 请联系运维人员,并发送已收集的故障日志信息。
参考信息
无。