ALM-12041关键文件权限异常(2.x及以前版本)
告警解释
系统每隔一个小时检查一次系统中关键目录或者文件权限、用户、用户组是否正常,如果不正常,则上报故障告警。
当检查到权限等均正常,则告警恢复。
告警属性
告警ID |
告警级别 |
可自动清除 |
---|---|---|
12041 |
严重 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
ServiceName |
产生告警的服务名称。 |
RoleName |
产生告警的角色名称。 |
HostName |
产生告警的主机名。 |
PathName |
异常的文件路径或者名称。 |
对系统的影响
导致系统功能不可用。
可能原因
用户手动修改了文件权限、用户和用户组等信息或者系统异常下电等原因。
处理步骤
- 检查异常文件权限。
- 登录MRS集群详情页面,选择“告警管理”。
- 查看该告警的详细信息,查看定位信息中对应的“HostName”字段值,获取该告警产生的主机名,查看定位信息中对应的“PathName”字段值,获取异常的文件路径或者名称。
- 登录告警节点。
- 执行ll pathName命令,其中pathName为前面获取到的异常文件,获取到该文件或者目录在主机上的当前的用户、权限、用户组等信息。
- 进入“${BIGDATA_HOME}/nodeagent/etc/agent/autocheck”目录,然后执行vi keyfile命令,并搜索对应的异常文件名,可以看到该文件的正确权限。
- 对比当前主机上该文件的真实权限和1.e中获取到的文件应有权限,对该文件进行正确的权限和用户,用户组信息的修改。
- 等待一个小时,进入下一次检查,查看告警是否恢复。
- 是,操作结束。
- 否,执行2。
- 收集故障信息。
- 在MRS Manager界面,单击“系统设置 > 日志导出”。
- 请联系运维人员,并发送已收集的故障日志信息。
参考信息
无。