ALM-12034 周期备份任务失败(2.x及以前版本)
告警解释
周期备份任务执行失败,则上报该告警,如果下次备份执行成功,则发送恢复告警。
告警属性
告警ID |
告警级别 |
可自动清除 |
---|---|---|
12034 |
严重 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
ServiceName |
产生告警的服务名称。 |
RoleName |
产生告警的角色名称。 |
HostName |
产生告警的主机名。 |
TaskName |
任务名称。 |
对系统的影响
周期备份任务失败,可能会导致长时间没有可用的备份包,在系统出现异常时,无法恢复。
可能原因
该告警产生原因依赖于该任务的详细情况,直接获取日志和任务详情来处理该告警。
处理步骤
查看磁盘空间是否不足
- 在MRS Manager界面,单击“告警管理”。
- 在告警列表中单击该告警的,从“定位信息”处获得“任务名”。
- 选择“系统设置 > 备份管理”。
- 根据“任务名”查找对应备份任务,选择“操作”栏下的“更多 > 查询历史”,查看备份任务的详细信息。
- 选择“详情 > 查看”,查看是否有“Failed to backup xx due to insufficient disk space, move the data in the /srv/BigData/LocalBackup directory to other directories.”的信息。
- 选择“备份路径 > 查看”,获取备份路径。
- 以root用户登录节点,执行以下命令查看节点挂载详情,用户密码为安装前用户自定义,请咨询系统管理员:
df -h
- 在挂载详情中查看备份路径挂载点的剩余空间是否小于20GB。
- 查看备份目录下是否有备份包,且份目录挂载节点剩余空间小于20GB。
- 将备份包移出备份目录,或者删除备份包,直到备份目录挂载节点剩余空间大于20GB。
- 再一次启动该备份任务,查看备份任务是否执行成功。
- 等待2分钟,检查告警是否消除。
- 是,结束执行。
- 否,执行13。
收集故障信息
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
无。