更新时间:2025-12-11 GMT+08:00
ALM-50405 JobServer终止作业接口时延超过阈值

本章节仅适用于MRS 3.5.1及之后版本。
告警解释
系统每30秒周期性检测JobServer中终止接口时延,当时延超出阈值(默认值为10秒)时,触发该告警。
当时延低于阈值时,告警恢复。
告警属性
告警ID | 告警级别 | 告警类型 | 业务类型 | 是否可自动清除 |
|---|---|---|---|---|
50405 | 紧急 | 处理错误告警 | JobGateway | 是 |
告警参数
类别 | 参数名称 | 参数含义 |
|---|---|---|
定位信息 | 来源 | 产生告警的集群或系统名称 |
服务名 | 产生告警的服务名称 | |
角色名 | 产生告警的角色名称 | |
主机名 | 产生告警的主机名 |
对系统的影响
用户执行终止作业时延较长。例如:通过REST接口终止作业响应时间较长。
可能原因
该节点JobServer的并发请求数激增,或者依赖底层服务(Yarn、HDFS等)响应时间较长。
处理步骤
- 登录FusionInsight Manager,选择“运维 > 告警 > 告警”,查找告警“JobServer终止作业接口时延超过阈值”,根据告警信息找到状态异常的JobServer实例节点,并从附加信息中找到当前告警值。
- 在告警页面中查找是否存在JobServer、Yarn或者HDFS的故障告警。
- 参考告警文档修复对应的告警故障,查看该告警是否恢复。
- 是,处理完毕。
- 否,执行步骤 4。
- 可暂时忽略,等待业务高峰过后,查看该告警是否恢复。
- 是,处理完毕。
- 否,执行步骤 5。
收集故障信息
- 在FusionInsight Manager首页,选择“运维 > 日志 > 下载”。
- 在“服务”中勾选待操作集群的“JobGateway”。
- 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
- 请联系运维人员,并发送已收集的故障日志信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。

