ALM-45736 Guardian服务不可用
本章节仅适用于MRS 3.1.5及之后版本。
告警解释
告警模块按60秒周期检测Guardian服务状态,当检测到Guardian服务异常时,系统产生此告警。
当系统检测到Guardian服务恢复正常,且告警处理完成时,告警恢复。
告警属性
告警ID |
告警级别 |
是否自动清除 |
---|---|---|
45736 |
紧急 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
角色名 |
产生告警的角色名称。 |
主机名 |
产生告警的主机名。 |
对系统的影响
当Guardian服务不可用时,业务无法正常访问OBS。
可能原因
- Guardian服务所依赖内部服务HDFS故障。
- TokenServer角色实例异常。
处理步骤
检查HDFS服务状态。
- 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”页面,查看系统是否上报“ALM-14000 HDFS服务不可用”告警。
- 参考ALM-14000 HDFS服务不可用告警帮助指导处理对应告警。
告警全部恢复后,等待几分钟,检查本告警是否恢复。
- 是,处理完毕。
- 否,执行3。
检查所有TokenServer实例。
- 以omm用户登录TokenServer实例所在节点,执行ps -ef|grep "guardian.token.server.Server"命令查看当前节点是否存在TokenServer进程。
- 在告警列表中查看“Guardian服务不可用”告警是否清除。
- 是,处理完毕。
- 否,执行5。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
无。