文档首页/ MapReduce服务 MRS/ 用户指南/ MRS集群运维/ MRS集群告警处理参考/ ALM-45617 CDL复制槽Slot积压数据量超过阈值
更新时间:2024-11-22 GMT+08:00
分享

ALM-45617 CDL复制槽Slot积压数据量超过阈值

告警解释

PostgreSQL或Opengauss(适用于MRS 3.3.0及之后版本)积压过多的WAL日志,可能导致PostgreSQL或Opengauss磁盘空间耗尽。系统每5分钟检查CDL任务配置的复制槽Slot积压数据量是否超过阈值,如果是,则产生该告警。复制槽Slot积压低于阈值,告警恢复。

告警属性

告警ID

告警级别

是否自动清除

45617

重要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

作业名

产生告警的作业名称。

数据库名

产生告警的数据库名称。

Slot名

产生告警的数据库复制槽名称。

积压量

Slot数据积压情况。

对系统的影响

WAL日志在源端数据库不断积压,可能导致源端PostgreSQL或Opengauss数据库磁盘空间耗尽,最终导致PostgreSQL或Opengauss数据库无法提供服务。

可能原因

CDL任务异常,数据停止处理;或源端数据库更新快,CDL数据处理较慢。

处理步骤

  1. 使用具有创建CDL任务的用户或者具有管理员权限的用户登录FusionInsight Manager。
  2. 选择“运维 > 告警 > 告警”,单击“告警ID”为“45617”所在行的,在“定位信息”中查看发生该告警的作业名称。
  3. 在告警列表中,查看是否存在该任务对应的“ALM-45616 CDL任务执行异常”告警。

  4. 选择“集群 > 服务 > CDL”,单击“CDLService UI”后的链接进入CDL WebUI界面,根据2中的任务名,在作业列表中查看是否有该作业。

    • 是,查看该作业是否异常。
      • 是,执行5
      • 否,存在数据处理慢问题,联系运维人员。
    • 否,执行7

  5. 单击该作业所在行的“运行异常”或“已失败”链接,根据弹出界面的报错信息进行故障修复。
  6. 按照任务报错信息处理完成后,重新运行作业,查看是否可以运行成功。

    • 是,任务运行成功,处理完毕。
    • 否,任务运行失败,执行7

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“CDL”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后30分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

复制槽Slot积压数据量低于阈值,则告警恢复,无需手动清除。

参考信息

无。

相关文档