ALM-45453 Keeper连接断开

本章节仅适用于MRS 3.6.0及之后版本。
告警解释
系统每分钟检测一次ClickHouse和Keeper的连接情况,如果检测连接失败,系统产生告警(告警原因为Keeper连接异常)。如果连续3次检测连接失败,系统产生告警(告警原因为Keeper连接断开)。
当系统检测到有一次连接成功,告警自动清除。
告警属性
告警ID | 告警级别 | 告警类型 | 业务类型 | 是否可自动清除 |
|---|---|---|---|---|
45453 | 紧急 | 业务质量告警 | ClickHouse | 是 |
告警参数
类别 | 参数名称 | 参数含义 |
|---|---|---|
定位信息 | 来源 | 产生告警的集群或系统名称。 |
服务名 | 产生告警的服务名称。 | |
角色名 | 产生告警的角色名称。 | |
主机名 | 产生告警的主机名。 |
对系统的影响
当ClickHouse与Keeper断连,将无法正常使用ClickHouse服务。
可能原因
- Keeper状态异常。
- ClickHouse业务压力过大。
处理步骤
检查ClickHouseKeeper状态是否异常。
- 在FusionInsight Manager首页,选择“集群 > 服务 > ClickHouse > ClickHouseKeeper”。
- 查看ClickHouseKeeper各实例是否正常。
- 选中运行状态不为良好的实例,选择“更多 > 重启实例”。
- 查看实例重启后运行状态是否为良好。
- 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。
- 是,处理完毕。
- 否,执行步骤 6。
检查ClickHouse业务压力是否过大
- 登录FusionInsight Manager页面,选择“运维 > 告警 > 告警”,查看当前告警“定位信息”中的角色名以及确认主机名所在的IP地址。
- 以客户端安装用户,登录客户端的节点,执行如下命令:
cd {客户端安装路径}
source bigdata_env
- 执行以下语句,查询系统表判断是否有业务频繁写入,若有相关业务,等待业务执行完成,查看告警是否清除。
SELECT query_id, user, FQDN(), elapsed, query FROM system.processes ORDER BY query_id;
- 是,操作结束。
- 否,执行步骤 9。
- 和用户确认是否有大批量数据写入,若是,请等待任务结束之后,查看告警是否消除。
- 是,操作结束。
- 否,执行步骤 10。
收集故障信息
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。

