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更新时间:2026-06-16 GMT+08:00
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ALM-45434 ClickHouse组件数据表中存在单副本

告警解释

ClickHouse组件检测到某个自定义逻辑集群存在单副本时,系统产生此告警。

当检测到自定义逻辑集群使用多副本时,告警自动清除。

告警属性

告警ID

告警级别

是否自动清除

45434

重要

告警参数

参数名称

参数含义

来源

产生告警的集群或系统名称

服务名

产生告警的服务名称

角色名

产生告警的角色名称

主机名

产生告警的主机名

对系统的影响

ClickHouse组件中存在单副本,当出现硬件故障时,无法恢复数据。

可能原因

ClickHouse节点其组件配置目录下的metrika.xml配置信息中存在单副本配置。

处理步骤

检查ClickHouse实例metrika.xml配置是否正常

  1. 在FusionInsight Manager页面告警列表中,单击此告警所在行的,查看该告警的主机名。在“主机”页面,根据对应的主机名,查看主机IP。
  2. 登录ClickHouse服务异常的实例主机节点,进入当前ClickHouse实例配置目录,执行如下命令:

    cd ${BIGDATA_HOME}/FusionInsight_ClickHouse_版本号/x_x_ClickHouseServer/etc

    cat metrika.xml

  3. 查看每个自定义逻辑集群中shard节点的数量,确认是否存在单副本,执行步骤 4

    如果一个shard中只包含一个节点,则表示集群中存在单副本逻辑集群,如下所示:

    <shard>
      <internal_replication>true</internal_replication>
      <replica>
        <host>host-name1</host>
        <port>port</port>
        <user>clickhouse</user>
        <password/>
      </replica>
    </shard>

收集故障信息

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“ClickHouse”。
  3. 在“主机”中选择异常的主机,单击“确定”。
  4. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  5. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

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