ALM-29005 Impalad JDBC连接数超过阈值
告警解释
以30s为周期检测连接到该Impalad节点的客户端连接数,当检测到的连接数超过自定义阈值(默认60)时,系统产生此告警。
当系统检测到客户端连接数减少到阈值以下时,告警将自动解除。
告警属性
告警ID |
告警级别 |
是否可自动清除 |
---|---|---|
29005 |
重要 |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
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定位信息 |
来源 |
产生告警的集群名称 |
服务名 |
产生告警的服务名称 |
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角色名 |
产生告警的角色名称 |
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主机名 |
产生告警的主机名 |
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附加信息 |
Trigger Condition |
系统当前指标取值满足自定义的告警设置条件 |
对系统的影响
后续新建立客户端连接可能会阻塞甚至失败。
可能原因
已经和Impala服务端建立的连接过多,或者阈值设定的太小。
处理步骤
- 在FusionInsight Manager首页,选择“运维 > 告警 > 阈值设置 > Impala > 连接数 > 已经连接到Impalad进程的JDBC数量” ,检查设置的阈值大小。
- 检查连接到当前Impalad的JDBC应用数,并关闭闲置的应用,观察告警是否自动清除。
- 是,操作结束。
- 否,执行3,修改并发客户端连接数。
- 在FusionInsight Manager首页,选择“集群 > Impala > 配置 > 全部配置 > Impalad > 自定义”,增加自定义参数 --fe_service_threads,该参数默认值64,请按照需要修改该值,单击“保存”按钮保存配置。
- 在所有客户端的查询任务都执行完成后,选择“实例”页签,勾选所有“Impalad”实例并重启。
重启全部实例,服务不可用。重启单个实例,会导致当前实例节点正在执行的任务失败,服务可用。
- 重启完成后检查告警是否消失。
- 是,操作结束。
- 否,执行6。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。