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更新时间:2026-06-10 GMT+08:00
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ALM-27011 DBService数据库死锁产生次数超过阈值

告警解释

系统每30秒周期性检查DBService数据库死锁产生次数,若采集的死锁次数连续n次(n为设定的平滑次数,默认值为3)超过设定阈值(默认为1)时,系统将产生此告警。

当平滑次数为1,DBService数据库死锁产生次数小于或等于阈值时,该告警恢复;当平滑次数大于1,DBService数据库死锁产生次数连续n次(n为设定的平滑次数)小于阈值的90%时,该告警恢复。

本章节仅适用于MRS 3.6.0-LTS.1及之后版本。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

27011

重要

业务质量告警

FusionInsight Manager

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

附加信息

门限值

告警触发的阈值。

当前值

当前采集的指标值。

对系统的影响

  • 数据库长期存在死锁可能会导致大量事务陷入相互等待,空转持有资源不工作,进而导致系统吞吐量和并发能力严重下降。
  • 死锁导致大量事务阻塞等待或反复重试,业务响应时间显著变长,甚至出现接口超时、前端无响应。

可能原因

  • 告警阈值配置不合理。
  • 数据库死锁产生次数超过阈值。

    系统资源不足或者不同事务以相反的顺序申请多个锁资源,在分布式多节点场景下形成全局环路等待。

处理步骤

检查阈值设置是否合理

  1. 在FusionInsight Manager,选择“运维 > 告警 > 阈值设置 > 待操作集群的名称 > DBService > 数据库 > DBService数据库死锁次数”,查看该告警阈值是否合理(默认值1为合理值)。

  2. 单击“操作”列的“修改”,根据实际服务的使用情况修改告警阈值。
  3. 选择“集群 > 服务 > DBService”,在“概览”页面查看“DBService数据库死锁次数”图表,检查数据库死锁产生次数是否低于设置的阈值。

  4. 等待2分钟查看告警是否自动恢复。

    • 是,处理完毕。
    • 否,执行步骤 5

检查数据库死锁产生次数

  1. omm用户登录DBService主管理节点,执行以下命令登录DBService数据库。

    gsql -p 20015 -U omm -W ${数据库密码}

  2. 执行以下SQL语句,查看数据库是否存在死锁。

    SELECT SUM(deadlocks) AS total_deadlocks FROM pg_stat_database;

    查询结果大于0,表示存在死锁;查询结果等于0,表示不存在死锁。

  3. 根据实际情况处理死锁的任务或者修改告警阈值,并等待2分钟,查看告警是否清除。

    • 是,执行完毕。
    • 否,执行步骤 8

收集故障信息

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“DBService”、“OMS”。
  3. 设置日志收集的主机,可选项,默认所有主机。
  4. 单击右上角的时间编辑按钮设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  5. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。

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