ALM-20002 Hue服务不可用
告警解释
系统按60秒周期性检测Hue服务状态。当Hue服务不可用时产生该告警。
当Hue服务恢复时,告警恢复。
告警属性
告警ID |
告警级别 |
是否自动清除 |
---|---|---|
20002 |
紧急 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
角色名 |
产生告警的角色名称。 |
主机名 |
产生告警的主机名。 |
对系统的影响
无法使用Hue原生界面,用户无法通过Hue页面对MRS大数据组件进行交互分析和数据处理。
可能原因
- Hue服务所依赖内部服务KrbServer故障。
- Hue服务所依赖内部服务DBService故障。
- 与DBService连接的网络异常。
处理步骤
检查KrbServer服务是否正常。
- 在FusionInsight Manager界面,选择“集群 > 待操作集群的名称 > 服务”,在服务列表中查看“KrbServer”的“运行状态”是否为“良好”。
- 手动重启KrbServer服务。
- 等待几分钟。检查“Hue服务不可用”告警是否恢复。
- 是,处理完毕。
- 否,执行4。
检查DBService是否正常
- 登录FusionInsight Manager界面,选择“集群 > 待操作集群的名称 > 服务”。
- 在服务列表中查看DBService服务运行状态是否为“良好”。
- 重启DBService服务。
重启服务期间服务不可用,业务中断。
- 等待几分钟。检查“Hue服务不可用”告警是否恢复。
- 是,操作结束。
- 否,执行8。
检查与DBService连接的网络是否正常
- 在FusionInsight Manager界面,选择“集群 > 待操作集群的名称 > 服务 > Hue > 实例”,记录主Hue的IP地址。
- 登录主Hue的IP地址。
- 执行ping命令,查看主Hue所在主机与DBService服务所在主机的网络连接是否正常。(获取DBService服务IP地址的方式和获取主Hue IP地址的方式相同。)
- 联系网络管理员恢复网络。
- 等待几分钟。检查“Hue服务不可用”告警是否恢复。
- 是,处理完毕。
- 否,执行13。
收集故障信息
- 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
- 在“服务”框中勾选如下节点信息。
- Hue
- Controller
- 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
- 请联系运维人员,并发送已收集的故障日志信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
无。