更新时间:2026-04-28 GMT+08:00
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ALM-19037 打开的连接数超阈值

告警解释

系统每30秒周期性检测每个HBase服务PhoenixQueryServer实例的连接使用率。当检测到某个PhoenixQueryServer上的连接使用率超出阈值(默认连续5次超过阈值)时产生该告警。当PhoenixQueryServer连接使用率小于或等于阈值时,告警清除。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

19037

紧急(默认阈值为100%)

重要(默认阈值为90%)

业务质量告警

HBase

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

附加信息

Threshold

产生告警的阈值。

对系统的影响

PhoenixQueryServer的连接使用率超出阈值,会影响PhoenixQueryServer对外提供服务的能力,导致PhoenixQueryServer处理客户端请求能力下降,业务读写时延变大或者请求失败。

可能原因

  • PhoenixQueryServer总连接数配置值过低。
  • 发送到该PhoenixQueryServer的请求存在热点问题。

处理步骤

  1. 登录Manager界面,选择“运维 > 告警 > 告警”,选择“告警ID”为“19037”的告警,查看“定位信息”中产生该告警的服务实例和主机名。

查看PhoenixQueryServer连接配置

  1. 选择“集群 > 服务 > HBase > 配置”,在界面右上角搜索“avatica.connectioncache.maxcapacity”,查看PhoenixQueryServer角色对应的该参数值是否过低,默认值为“200”。

  2. 根据实际业务适当调大参数值并单击“保存”保存配置。单击“实例”,勾选受影响的“PhoenixQueryServer”实例,选择“更多 > 滚动重启 ”,在弹出的界面中输入用户和密码,单击“确定”,等待滚动重启完成,使其生效。
  3. 配置生效后,在告警列表中,查看本告警是否清除。

    • 是,处理完毕。
    • 否,执行步骤 5

检查发送到该PhoenixQueryServer的请求是否存在热点问题

  1. 在Manager首页,选择“集群 > 服务 > HBase> 图表”,在“图表分类”中选择“连接”,查看“连接打开的数量-所有实例”图表中所有PhoenixQueryServer实例的连接打开数量Top3。如果存在明显PhoenixQueryServer实例使用热点,即Top1的连接数量明显高于Top2或Top3,请调整业务访问其余的PhoenixQueryServer节点。
  2. 执行完业务调整后,等待一段时间,再登录Manager界面,选择“运维 > 告警 > 告警”,观察该告警是否清除。

    • 是,处理完毕。
    • 否,执行步骤 7

收集故障信息

  1. 在Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“HBase”。
  3. 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。

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