更新时间:2024-11-22 GMT+08:00
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ALM-17009 Oozie连接DBService状态异常

告警解释

Oozie会依赖DBService,提交任务后系统会检测DBService连接状态,当检测到与DBService的连接状态连续10次异常时,产生该告警。

当检测到Oozie连接DBService状态正常时,告警清除。

告警属性

告警ID

告警级别

是否可自动清除

17009

次要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

Trigger Condition

系统当前指标取值满足自定义的告警设置条件。

对系统的影响

正在运行的调度任务会阻塞,无法提交新的调度任务。

可能原因

  • DBService服务异常。
  • Oozie连接DBService异常。

处理步骤

检查DBService服务状态。

  1. 在FusionInsight Manager的服务列表中,查看DBService运行状态是否为“良好”。

    • 是,执行5
    • 否,执行2

  2. 在告警列表中,查看是否有“ALM-27001 DBService服务不可用”告警产生。

    • 是,执行3
    • 否,执行5

  3. 参考ALM-27001 DBService服务不可用的处理步骤处理该故障。
  4. 等待几分钟后,在告警列表中查看“Oozie连接DBService状态异常”告警是否清除。

    • 是,处理完毕。
    • 否,执行5

检查Oozie与DBService连接是否异常。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 在线检索”,选择“Oozie”服务,检索日志关键词“[Oozie Alarm Enhancement][DB Service]”,在日志中查看具体告警原因,并进行处理。在告警列表中查看“Oozie连接DBService状态异常”告警是否清除。

    • 是,处理完毕。
    • 否,执行6

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”框中勾选待操作集群的“Oozie”,单击“确定”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。

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