ALM-12188 diskmgt磁盘监控服务不可用
告警解释
NodeAgent每隔5分钟检测diskmgt磁盘监控服务状态,当diskmgt磁盘监控服务不可用时产生此告警。
diskmgt磁盘监控服务恢复时,告警清除。
告警属性
告警ID |
告警级别 |
是否可自动清除 |
---|---|---|
12188 |
次要 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
来源 |
产生告警的集群或系统名称。 |
服务名 |
产生告警的服务名称。 |
角色名 |
产生告警的角色名称。 |
主机名 |
产生告警的主机名。 |
对系统的影响
diskmgt磁盘监控服务不可用时,影响系统对磁盘信息和分区信息的监控,如设备分区文件系统只读检测、设备分区丢失检测、磁盘分区扩容检测等。
可能原因
- diskmgt磁盘监控服务不存在。
- diskmgt磁盘监控服务未启动。
处理步骤
检查diskmgt磁盘监控服务是否存在。
- 登录FusionInsight Manager页面,选择“运维 > 告警 > 告警”,查看该告警的详细信息,在定位信息中查看发生该告警的主机名称。单击主机名称,查看对应的IP地址。
- 使用root用户登录告警上报主机IP节点。
- 执行以下命令查看服务核心文件是否存在。
stat /usr/local/diskmgt/inner/diskmgtd
如果不存在请联系运维人员进行处理。
启动diskmgt磁盘监控服务。
- 执行以下命令启动diskmgt磁盘监控服务。
systemctl restart diskmgt
- 执行以下命令查看diskmgt磁盘监控服务是否启动成功。
systemctl status diskmgt
- 是,回显类似如下,说明服务启动成功,执行6。
- 否,请联系运维人员进行处理。
- 是,回显类似如下,说明服务启动成功,执行6。
- 等待5分钟后,在Manager页面选择“运维 > 告警 > 告警”页签,查看该告警是否清除。
- 是,处理完毕。
- 否,请联系运维人员进行处理。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。