更新时间:2024-11-22 GMT+08:00
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ALM-12067 tomcat资源异常

告警解释

HA每85秒周期性检测Manager的Tomcat资源。当HA连续2次都检测到Tomcat资源异常时,产生该告警。

当HA检测到Tomcat资源正常后,告警恢复。

Tomcat资源为单主资源,一般资源异常会导致主备倒换,看到告警时,基本已经主备倒换,并在新主环境上启动新的Tomcat资源,告警恢复。该告警用于提示用户,Manager主备倒换的原因。

MRS 3.3.1及之后版本,告警名称从“tomcat资源异常”变成“Manager tomcat资源异常”。

告警属性

告警ID

告警级别

是否自动清除

12067

重要

告警参数

参数名称

参数含义

来源

产生告警的集群或系统名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

可能引起Manager主备倒换。Manager和组件WebUI服务不可用,无法对Web上层应用正常提供集群管理功能,可能引起无法登录Manager和组件的WebUI。

可能原因

  • Tomcat目录权限异常,Tomcat进程异常。

处理步骤

检查Tomcat目录权限是否正常。

  1. 打开FusionInsight Manager页面,在告警列表中,单击此告警所在行的,查看该告警的主机地址。
  2. root用户登录告警所在主机,用户密码为安装前用户自定义,请咨询系统管理员
  3. 执行命令su - omm,切换到omm用户。
  4. 执行命令vi $BIGDATA_LOG_HOME/omm/oms/ha/scriptlog/tomcat.log,查看ha的Tomcat资源日志,是否有如下关键字“Cannot find XXX,根据如下关键字修复对应文件的权限。
  5. 等待5分钟,查看告警是否自动清除。

    • 是,处理完毕。
    • 否,执行6

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维>日志>下载”。
  2. 在“服务”中勾选“OmmServer”和 “Tomcat”,单击“确定”。
  3. 单击右上角的设置日志收集的时间范围,一般为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

无。

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