问题现象
MRS集群创建成功后,登录集群Manager页面或者修改用户密码失败。
原因分析
- 登录到集群的Kerberos服务节点,查看“/var/log/Bigdata/kerberos/krb5kdc.log”。
- 登录到主、备OMS节点,查看“/var/log/Bigdata/okerberos/oms-krb5kdc.log”。
发现有大量的认证失败,同时有 “<unknown client> for <unknown server>”错误提示。
- 通过排查,发现是由于节点安装了原生的Kerberos导致认证异常。
执行rpm -qa | grep krb5,观察是否有krb5-workstation-1.10.3-33.el6.x86_64。
处理步骤
- 执行以下命令卸载“krb5-workstation”软件和依赖的软件:
rpm -e krb5-workstation-1.10.3-33.el6.x86_64
- 在Kerberos服务节点上使用kill -9命令结束Kerberos的进程,等待其重启即可。