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更新时间:2023-12-12 GMT+08:00
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Agent安装失败问题排查

数据采集时,需要在ECS上安装Agent,当出现安装失败等问题时,请参照本章节进行排查处理:

可能原因

Agent安装失败的可能原因如下:

  • 待安装Agent的ECS服务器与存储Agent的OBS桶之间网络不通
  • ECS服务器的磁盘空间不足
  • 调用iamtoken请求,获取iamtoken失败
  • workspaceId校验失败
  • Agent已经安装,系统仍将重复安装

原因排查及解决方法

  • 待安装Agent的ECS服务器与存储Agent的OBS桶之间网络不通
    图1 主机与OBS网络不通

    解决方法

    • (可选)方法一:将ECS主机与OBS的网络连通。
    • (可选)方法二:手动将安装脚本以及安装包下载到本地后,再将安装包上传到主机的“/opt/cloud”路径下。
      1. 登录OBS管理控制台。
      2. 在左侧导航栏选择“桶列表”,并单击目标桶名称,进入桶对象管理页面。
      3. 单击目标桶对象名称,进入桶对象详情页面后,下载安装脚本和安装包。
      4. 通过远程管理工具(如:SecureFX、WinSCP)远程登录目标云服务器。
      5. 将安装包上传到主机的“/opt/cloud”路径下。
  • ECS主机的磁盘空间不足
    图2 磁盘空间不足

    解决方法

    清理磁盘,预留足够空间。

  • 调用iamtoken请求,获取iamtoken失败
    • 问题现象

      当日志出现如下图所示信息时,则表示调用iamtoken请求,获取iamtoken失败。

      图3 获取iamtoken失败
    • 排查步骤和解决方法
      1. 确认执行命令中的IAM账号或用户名是否有误。
        图4 IAM用户名和密码
        • 有误,修改命令中的IAM账号或用户名后再次执行安装命令。
        • 无误,继续执行2
      2. 执行vim /etc/salt/iam_token.txt命令,查看“/etc/salt/iam_token.txt”文件检查是否存在。
        • 当出现如下图信息时,则表示存在,继续执行3
          图5 检查文件
        • 如果提示文件不存在,请联系技术支持进行处理。
      3. 执行ping 命令,检查主机是否可以连通网络地址,如果不通,用户需要打通网络。
        图6 检查网络
  • workspaceId校验失败
    • 问题现象
      当日志出现如下图所示信息时,则表示Workspace ID校验失败。
      图7 workspaceId校验失败
    • 解决方法
      1. 登录安全云脑管理控制台。
      2. 在左侧导航栏选择工作空间 > 空间管理,并在工作空间列表中,单击目标工作空间名称,进入目标工作空间管理页面。
      3. 在左侧导航栏选择设置 > 组件管理,进入节点管理页面后,单击目标节点名称。
      4. 查看执行命令中的workspaceId和projectId。
        图8 控制台中的参数信息
      5. 查看实际运行命令中的workspaceId和projectId,是否与4中的一致。
        图9 命令中的参数信息
      6. 修改实际执行命令中的workspaceId和projectId。
  • Agent已经安装,系统仍将重复安装
    • 问题现象
      当日志出现如下图所示信息时,则表示Agent已经安装。
      图10 Agent重复安装
    • 解决方法
      1. (可选)方法一:通过管理控制台注销该节点。
        1. 登录安全云脑管理控制台。
        2. 在左侧导航栏选择工作空间 > 空间管理,并在工作空间列表中,单击目标工作空间名称,进入目标工作空间管理页面。
        3. 在左侧导航栏选择设置 > 组件管理,进入节点管理页面后,单击目标节点所在行“操作”列的“注销”
        4. 在弹出的确认框中,单击“确认”
      2. (可选)方法二:通过脚本命令卸载Agent。
        1. 通过远程管理工具(如:SecureFX、WinSCP)远程登录目标云服务器。
        2. 执行sh /opt/cloud/agent_controller_euler.sh uninstall命令,卸载Agent。
      3. 检查是否已完成卸载。
        1. 通过远程管理工具(如:SecureFX、WinSCP)远程登录目标云服务器。
        2. (可选)方法一:执行ls -a /opt/cloud/查看“/opt/cloud”目录下的文件,当提示如下图所示信息(只有脚本文件)时,则表示已完成卸载。
          图11 脚本文件
        3. (可选)方法二:执行salt-minion --version命令,当提示如下图所示信息时,则表示已卸载完成。
          图12 检查Agent信息

      节点注销需要一定的时间,不建议点完注销立刻安装。

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