更新时间:2022-02-17 GMT+08:00
分享

配置Python环境

前提条件

  • 确保已安装Python3,目前Python SDK仅支持Python3。
  • 确保已安装setuptools、requests、websocket-client。

操作步骤

  1. 下载SDK,通过pip-list命令查看安装包。若未安装,则执行以下命令:
    pip install setuptools
    pip install requests
    pip install websocket-client
  2. 进入下载的Python SDK目录,在setup.py所在层目录执行 python setup.py install 命令,完成SDK安装。

版本说明

websocket-client 在1.x版本以后,新增了onclose接口的入参,导致和之前旧版本不兼容。sdk1.7.1版本已解决该兼容性问题,旧版本sdk如果在使用实时流遇到onclose参数报错,可考虑更新sdk解决问题。

分享:

    相关文档

    相关产品

关闭导读