更新时间:2024-09-03 GMT+08:00
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特征库升级失败排查方法

现象描述

系统 > 升级中心中查看入侵防御特征库、反病毒特征库升级失败,或者单击“立即升级”时出现报错。

可能原因

  • 本地授权时,license过期
  • 云端授权时,license过期或设备还没有上线。
  • 设备和升级中心网络不通。
  • 设备存储卡空间和系统内存不足。
  • 检查update run-log错误码,明确错误原因。

处理步骤

  1. 执行如下命令检查是否是云端授权。

    Local Entitlement Mode表示本地授权,Cloud Entitlement Mode表示云端授权模式。

    <sysname> display license entitlement-mode 
    License Entitlement Mode: Local Entitlement Mode
  2. 如果是本地授权,请按照如下步骤处理。
    1. 选择系统 > License管理,查看License是否过期或者未授权,如果是已授权请执行4
    2. 如果过期或者未授权请重新申请License,然后导入并激活。

  3. 如果是云端授权,请按照如下步骤处理。
    1. 以租户身份登录华为乾坤控制台,单击右上角租户名称,选择“订单中心”,查找威胁防护库升级服务套餐是否过期,如果没有过期请执行c
    2. 如果过期重新申请威胁防护库升级服务License,然后在“我的套餐”页签,单击如下红色框区域,并跟根据提示完成开通。

    3. 选择资源中心 > 设备管理,查看此设备状态是否正常。
    4. 如果没有在线,请参照设备上线指导完成设备上线,如果无法上线请参照设备无法上线排查方法处理。
    5. 在设备在线后,设备中的北向连接“已连接”状态要保持3分钟以上,然后再尝试击“立即升级”,如果升级不成功请执行4
  4. 检查设备公网的连通性。

    基本知识:设备升级时需要连接sec.huawei.com进行认证,同时获取库存储服务器的域名或者IP地址,然后根据获取的域名或IP地址进行FTP或HTTPS连接下载库文件。

    1. 请在设备上单击“测试升级中心连接”

    2. 如果提示如下信息表示连接成功,否则请执行下一步。

    3. 请检查是否配置了正确的DNS服务器或者确认此DNS服务器是否能正常解析。
    4. 如果设备配置了安全策略等,需要检查配置确认是否允许报文从设备出接口出去。
  5. 检查设备存储卡空间和系统内存。
    1. 通过命令行(dir)或web检查设备存储卡剩余空间是否满足要求。

      如果是因为存储卡空间不足导致升级失败,则设备会给出相应的提示信息,需要删除存储卡上一些废弃的文件(比如存在多个软件包)以释放一些空间后重试。

      (升级库需要的空间依赖产品的机型,需要查看防火墙产品文档)。

    2. 通过命令行(display memory-usage)检查剩余内存是否满足要求。

      如果因为内存不足导致升级失败,则设备也会给出相应的提示信息,需要联系研发工程师进行问题定位。

  6. 查看run-log信息,找到错误码,定位最终原因,针对原因解决问题。

    在诊断视图执行display update run-log命令查看完整的run-log信息,或执行display update run-log to-file将run-log信息保存至update-runlog.txt文件中。搜索“error code is”,查看后面以0x开头的错误码。

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