更新时间:2024-08-20 GMT+08:00
分享

删除桶失败

问题描述

无法删除已创建的OBS桶。

排查思路

以下排查思路根据原因的出现概率进行排序,建议您从高频率原因往低频率原因排查,从而帮助您快速找到问题根因。

如果处理完某个可能原因仍未解决问题,请继续排查其他可能原因。

图1 删除桶失败排查思路
表1 排查思路

可能原因

处理措施

本地网络故障

检查本地与OBS之间的网络是否正常,如果存在网络故障,解决网络故障,确保网络正常。

桶内对象未全部删除

请参考删除桶内对象

桶内已删除对象未彻底删除

请参考彻底删除桶内已删除对象

桶内碎片未全部删除

请参考删除桶内碎片

无删除桶的权限

请参考检查是否有删除桶的权限

删除桶内对象

以下步骤以控制台手动删除操作为例,通过其他方式(如obsutil、SDK等)删除的方法,请参见删除对象。您还可以通过生命周期管理功能,一次性清空桶中所有对象。

  1. 在OBS控制台桶列表单击待操作的桶,进入“对象”页面。
  2. 批量勾选所有对象,单击对象列表上方的“删除”。
    图2 删除所有对象

删除所有对象后请再次尝试删除桶,如果仍然无法删除,请继续下面的操作。

彻底删除桶内已删除对象

对于已经开启或曾经开启过多版本控制功能的桶,可能存在已删除对象,需要确保已删除对象已经被彻底删除。关于已删除对象的介绍,请参见多版本控制功能启用时的对象删除机制

  1. 在OBS控制台桶列表单击待操作的桶,进入“对象”页面。
  2. 单击上方的“已删除对象”页签,进入已删除对象列表。
  3. 批量勾选所有已删除对象,单击列表上方的“彻底删除”。
    图3 删除所有已删除对象

彻底删除所有已删除对象后请再次尝试删除桶,如果仍然无法删除,请继续下面的操作。

删除桶内碎片

桶中不完整的数据称之为碎片。OBS采用分块上传的模式上传数据,在下列情况下(但不仅限于此)通常会导致数据上传失败而产生碎片。

  • 网络条件较差,与OBS的服务器之间的连接经常断开。
  • 上传过程中,人为中断上传任务。
  • 设备故障。
  • 突然断电等特殊情况。

以下步骤以控制台手动删除碎片为例。通过其他方式删除碎片的方法,请参见清理碎片

  1. 在OBS控制台桶列表单击待操作的桶,进入“对象”页面。
  2. 单击上方的“碎片”页签,进入碎片列表。
  3. 选中所有碎片,单击列表上方的“删除”。
    图4 删除所有碎片

删除所有碎片后请再次尝试删除桶,如果仍然无法删除,请继续下面的操作。

检查是否有删除桶的权限

默认情况下,只有桶拥有者具备删除桶的权限。桶拥有者也可以给其他人授予删除桶(DeleteBucket)的权限。

  1. 确认自己是否是桶拥有者。
    1. 在OBS控制台桶列表单击待操作的桶,进入“对象”页面。
    2. 在左侧导航栏单击“概览”,进入“概览”页面。
    3. 在“基本信息”区域查看“账号ID”。该账号ID为桶拥有者。
      图5 查看桶拥有者
    4. 鼠标指向控制台右上角自己的用户名,在下拉菜单中单击“我的凭证”,查看自己的“账号ID”。
      图6 查看自己的账号ID
      • 如果两个账号ID相同,且自己属于账号而非IAM用户,则说明自己是桶拥有者。此时仍无法删除桶,请单击下方提交工单链接寻求更多帮助。
      • 如果两个账号ID相同但自己属于IAM用户,或账号ID不同,则说明自己不是桶拥有者。此时请继续下一步。
  2. 联系桶拥有者,确认是否已授予删除桶的权限。
    • 如果未授予删除桶的权限,请联系桶拥有者授权。
    • 如果已授予删除桶的权限,仍然无法删除桶,请单击下方提交工单链接寻求更多帮助。

提交工单

如果上述方法均不能解决您的疑问,请提交工单联系华为云客服为您解答。

相关文档