更新时间:2024-09-04 GMT+08:00
ALM-12038 监控指标转储失败(2.x及以前版本)
告警解释
用户在MRS Manager界面配置监控指标转储后,转储失败时产生该告警。
转储成功后,告警恢复。
告警属性
告警ID |
告警级别 |
可自动清除 |
---|---|---|
12038 |
严重 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
ServiceName |
产生告警的服务名称。 |
RoleName |
产生告警的角色名称。 |
HostName |
产生告警的主机名。 |
对系统的影响
监控指标转储失败会影响上层管理系统无法获取到MRS Manager系统的监控指标。
可能原因
- 无法连接服务器。
- 无法访问服务器上保存路径。
- 上传监控指标文件失败。
处理步骤
- 联系运维人员查看MRS Manager系统与服务器网络连接是否正常。
- 联系运维人员恢复网络连接,然后检查告警是否恢复。
- 是,执行完毕。
- 否,执行3。
- 单击“系统设置 > 监控指标转储配置”,查看监控转储配置页面配置的FTP用户名、密码、端口、转储模式、公钥是否与服务器端配置一致。
- 填入正确的配置信息,然后单击“确定”,并检查告警是否恢复。
- 是,执行完毕。
- 否,执行5。
- 单击“系统设置 > 监控指标转储配置”,查看“FTP用户名”、“保存路径”和“转储模式”配置项。
- 登录服务器,在默认目录下查看相对路径“保存路径”是否有“FTP用户名”的读写权限。
- 登录服务器,查看绝对路径“保存路径”是否有“FTP用户名”的读写权限。
- 增加读写权限,然后检查告警是否恢复。
- 是,执行完毕。
- 否,执行9。
- 登录服务器,查看当前保存路径下是否有足够磁盘空间。
- 删除多余文件,或在监控指标转储配置页面更改保存目录。然后检查告警是否恢复。
- 是,执行完毕。
- 否,执行11。
- 收集故障信息。
- 在MRS Manager界面,单击“系统设置 > 日志导出”。
- 请联系运维人员,并发送已收集的故障日志信息。
参考信息
无。
父主题: MRS集群告警处理参考