更新时间:2024-09-04 GMT+08:00

ALM-12172 指标上报CES失败

告警解释

集群开启指标共享后,controller周期性的收集集群指标信息并上报到CES。

告警属性

告警ID

告警级别

是否自动清除

12172

重要

告警参数

参数名称

参数含义

来源

产生告警的集群或者系统名称

服务名

产生告警的服务名称

角色名

产生告警的角色名称

主机名

产生告警的主机名

对系统的影响

监控指标上报CES失败,在CES中无法看到MRS云服务的监控指标。

可能原因

  • 权限问题请求CES接口失败
  • 网络问题上报CES数据失败。
  • 服务内部问题导致上报CES数据失败。

处理步骤

  1. 打开FusionInsight Manager 页面,选择“运维 > 告警 > 告警”,查看告警详细信息中的附加信息。
  2. 根据以下场景处理。

    • 告警附加信息中显示“Call CES to send metrics fail. Permission exception”,表示资源租户token失效。需要重启controller,重新获取token。操作步骤如下:
      1. 登录FusionInsight Manager界面,单击右上角任务中心图标,确认任务管理中心无执行中的任务。
      2. 使用PuTTY工具,以omm用户登录主管理节点。
      3. 执行以下命令重启controller。

        sh ${BIGDATA_HOME}/om-server/om/sbin/restart-controller.sh

      4. 重启完成后,等待五分钟,观察告警是否恢复。
        • 是,操作结束。
        • 否,请执行3
    • 告警附加信息中显示“Call CES to send metrics fail. Request CES error code xxx”或“CES internal error code xxx”, 表示功能服务存在异常,请执行3
    • 告警附加信息中显示“Call CES to send metrics fail. Too many request”,表示服务请求触发流控,请执行3

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选“OMS > Controller”,“主机”选择主节点,单击“确定”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

无。