更新时间:2024-11-29 GMT+08:00

ALM-47000 MemArtsCC实例不可用

告警解释

告警模块按60秒周期检测MemArtsCC实例状态,当检测到当前节点MemArtsCC实例异常时,系统产生此告警。

当系统检测到任一MemArtsCC实例恢复正常,且告警处理完成时,告警恢复。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

47000

重要

处理错误告警

MemArtsCC

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群或系统名称

服务名

产生告警的服务名称

角色名

产生告警的角色名称

主机名

产生告警的主机名

对系统的影响

MemArtsCC服务异常,无法通过FusionInsight Manager对MemArtsCC进行集群操作,无法使用MemArtsCC服务功能。

可能原因

  • 配置错误,集群未成功启动。
  • Zookeeper服务异常。

处理步骤

检查MemArtsCC配置

  1. root用户登录任一MemArtsCC安装节点,进入CCWorker日志路径“/var/log/Bigdata/memartscc/ccworker”,查看CCWorker启动日志。
  2. 根据日志中打印的错误的配置项,更正配置项后,重启服务。
  3. 等待5分钟,检查该告警是否恢复。

    • 是,处理完毕。
    • 否,执行4

检查ZooKeeper服务实例状态。

  1. 在FusionInsight Manager首页,选择“集群 > 服务 > ZooKeeper > 实例”。
  2. 查看ZooKeeper各实例是否正常。

    • 是,执行9
    • 否,执行6

  3. 选中ZooKeeper运行状态不为良好的实例,选择“更多 > 重启实例”。
  4. 查看实例重启后运行状态是否为良好。

    • 是,执行8
    • 否,执行9

  5. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行9

收集故障信息

  1. 在FusionInsight Manager首页,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“MemArtsCC”。
  3. 单击右上角的编辑按钮设置日志收集的“开始时间”和“结束时间”,分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息