文档首页/ MapReduce服务 MRS/ 用户指南(安卡拉区域)/ 告警参考/ ALM-46004 MOTService主备数据不同步
更新时间:2024-11-29 GMT+08:00

ALM-46004 MOTService主备数据不同步

告警解释

系统每10秒检查一次MOTService主备数据同步状态,如果连续6次查不到同步状态,或者同步状态异常,产生此告警。

当同步状态正常,告警恢复。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

46004

紧急

业务质量告警

MOTService

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

附加信息

本端MOTService HA名

本地MOTService HA名称。

对端MOTService HA名

对端MOTService HA名称。

对系统的影响

主备MOTServer数据不同步,如果此时主实例异常,则会导致数据丢失或者数据异常。

可能原因

  • 主备节点网络不稳定。
  • 备MOTService异常。
  • 备节点磁盘空间满。
  • 主MOTService节点GaussDB进程CPU使用率高(需要通过日志定位该问题)。

处理步骤

检查主备节点网络是否正常。

  1. 在FusionInsight Manager页面,选择“集群 > 服务 > MOTService > 实例”,查看并记录“MOTServer (主)”和“MOTServer (备)”的业务IP地址。
  2. omm用户登录“MOTServer (主)”节点。
  3. 执行以下命令检查主备MOTService节点是否连通。

    ping MOTServer (备)业务IP
    • 是,执行6
    • 否,执行4

  4. 联系网络管理员查看是否为网络故障。

    • 是,执行5
    • 否,执行6

  5. 修复网络故障,查看告警列表中,该告警是否已清除。

    • 是,处理完毕。
    • 否,执行6

检查备MOTService状态是否正常

  1. omm用户登录“MOTServer (备)”节点。
  2. 执行如下命令检查备MOTService的GaussDB资源状态是否正常。

    cd ${MOTSERVER_HOME}/sbin

    ./status-motserver.sh

    例如,查看“ResName”为“gaussDB”的行,显示如下表示正常:

    10_10_10_231 gaussDB Standby_normal Normal Active_standby
    • 是,执行8
    • 否,执行14

检查备节点磁盘是否已满。

  1. omm用户登录备MOTService节点。
  2. 进入“${MOTSERVER_HOME}”目录,执行以下命令获取MOTservice的数据目录。

    cd ${MOTSERVER_HOME}

    source .motservice_profile

    echo ${MOTSERVICE_DATA_DIR}

  3. 执行df -h命令,查看系统磁盘分区的使用信息。
  4. 查看MOTService数据目录空间是否已满。

    • 是,执行12
    • 否,执行14

  5. 对节点磁盘进行扩容。
  6. 磁盘扩容后,等待2分钟检查告警是否清除。

    • 是,操作结束。
    • 否,执行14

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选“MOTService”,单击“确定”。
  3. 在“主机”中勾选对应角色所在的主机。
  4. 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  5. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。