更新时间:2024-11-29 GMT+08:00
ALM-45192 获取IAM securitytoken失败
告警解释
meta调用ECS接口获取AK/SK信息,若对用户设置了权限,则还需要访问IAM接口获取securityToken,当连续三次调用IAM接口失败时就会产生该告警。
当meta服务调用IAM接口成功时,告警清除。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
45192 |
重要 |
处理错误告警 |
meta |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名称。 |
对系统的影响
存算分离场景下,集群由于获取不到最新的securityToken,可能导致配置了细粒度权限的用户访问OBS失败,引起组件业务无法正常处理。
可能原因
- MRS集群meta角色状态异常。
- IAM服务异常。
处理步骤
检查meta角色状态。
- 在集群的FusionInsight Manager首页,选择“运维 > 告警 > 告警”,单击此告警所在行的,检查该告警的“定位信息”,查看告警上报的实例主机名。
- 在集群的FusionInsight Manager首页,选择“集群 > 服务 > meta”,单击“实例”,查看告警产生的主机对应的meta角色状态是否正常。
- 勾选状态异常的角色,选择“更多 > 重启实例”重启异常状态的meta角色。
- 查看当前告警是否恢复。
- 是,操作结束。
- 否,执行5。
- 登录1查询到的主机名,查看“/var/log/Bigdata/meta/mrs-meta.log”日志中是否有报错,根据日志进行排查处理。
- 查看当前告警是否恢复。
- 是,操作结束。
- 否,执行7。
收集故障信息
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。
父主题: 告警参考