更新时间:2024-11-29 GMT+08:00
ALM-23003 Loader任务执行失败
告警解释
当系统检测到Loader任务执行失败时即时产生该告警。当用户手动处理执行失败的任务后该告警恢复。该告警需要手动清除。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
23003 |
次要 |
业务质量告警 |
Loader |
否 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
|
附加信息 |
任务ID |
执行失败的Loader任务的ID。 |
任务名 |
执行失败的任务名称。 |
|
用户标识 |
提交Loader任务的用户。 |
|
Details |
对告警信息补充。 |
对系统的影响
Loader作业级别告警,执行提交的Loader任务时发生异常导致执行失败,需要用户查看具体日志来确认失败原因,没有返回执行结果。故障修复后需重新执行任务。对Loader服务没有影响。
可能原因
- 任务参数没有正确设置。
- Yarn执行任务时出现异常。
处理步骤
检查任务参数是否没有正确设置。
- 打开FusionInsight Manager页面,选择“运维 > 告警 > 告警”在告警列表中,打开告警下拉页面,获取告警原因。
- 如果告警原因是“提交任务失败”,则查看“附加信息”中的错误细节信息,同时到Loader界面查看该任务的历史执行记录。
admin用户默认不具备其他组件的管理权限,如果访问组件原生界面时出现因权限不足而打不开页面或内容显示不全时,可手动创建具备对应组件管理权限的用户进行登录。
- 重新提交任务。
- 查看任务是否成功执行。
检查Yarn执行任务时是否出现异常。
- 打开FusionInsight Manager页面,在告警列表中,打开告警下拉页面,获取告警原因。
- 在告警原因中查看Yarn活动是否正常执行,如果告警原因是“Yarn执行失败”则表示异常。
- 重新提交任务。
- 查看任务是否成功执行。
- 在告警列表中,单击该告警“操作”列下面的“清除”,手动清除告警。操作结束。
收集故障信息。
告警清除
此告警修复后,系统不会自动清除此告警,需手工清除。
参考信息
不涉及。
父主题: 告警参考