更新时间:2024-11-29 GMT+08:00
ALM-12004 Manager Oldap资源异常
告警解释
系统按60秒周期检测Ldap资源,当连续6次监控到Manager中的Ldap资源异常时,系统产生此告警。
当Manager中的Ldap资源恢复,且告警处理完成时,告警恢复。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
12004 |
重要 |
业务质量告警 |
FusionInsight Manager |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群或系统名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
对系统的影响
可能引起Manager主备倒换。Manager和组件WebUI认证服务不可用,无法对Web上层服务提供安全认证和用户管理功能,可能引起无法登录Manager和组件的WebUI。
可能原因
Manager中LdapServer进程故障。
处理步骤
检查Manager中LdapServer进程是否正常。
- 以omm用户登录集群中的Manager所在节点主机。
可以通过登录FusionInsight Manager浮动IP节点,执行sh ${BIGDATA_HOME}/om-server/om/sbin/status-oms.sh命令来查看当前Manager的双机信息。
- 执行ps -ef | grep slapd,查询配置文件位于“${BIGDATA_HOME}/om-server/om/”路径下面的LdapServer资源进程是否正常。
- 执行kill -2ldap进程pid,等待20s以后,HA会自动启动OLdap进程。观察当前OLdap资源状态是否正常。
- 是,操作结束。
- 否,执行4。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。
父主题: 告警参考