更新时间:2024-11-29 GMT+08:00

ALM-12005 Manager OKerberos资源异常

告警解释

告警模块对Manager中的Kerberos资源的状态按80秒周期进行监控,当连续6次监控到Kerberos资源异常时,系统产生此告警。

当Kerberos资源恢复时,且告警处理完成时,告警恢复。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

12005

重要

业务质量告警

FusionInsight Manager

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群或系统名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

Manager中的Kerberos资源异常,组件WebUI认证服务不可用,无法对Web上层服务提供安全认证功能,可能引起无法登录FusionInsight Manager和组件的WebUI。

可能原因

Okerberos依赖的OLdap资源异常。

处理步骤

检查Manager中的OKerberos依赖的OLdap资源是否异常。

  1. omm用户登录到集群中Manager所在节点主机。

    通过登录FusionInsight Manager浮动IP节点,执行sh ${BIGDATA_HOME}/om-server/om/sbin/status-oms.sh脚本来查看当前Manager的双机信息。

  2. 执行sh ${BIGDATA_HOME}/om-server/OMS/workspace0/ha/module/hacom/script/status_ha.sh,查询当前HA管理的OLdap资源状态是否正常(单机模式下面,OLdap资源为Active_normal状态;双机模式下,OLdap资源在主节点为Active_normal状态,在备节点为Standby_normal状态。)。

    • 是,执行4
    • 否,执行3

  3. 参考ALM-12004 Manager Oldap资源异常的处理步骤进行处理,OLdap资源状态恢复后,观察当前OKerberos资源状态是否恢复正常。

    • 是,操作结束。
    • 否,执行4

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维>日志>下载”。
  2. 在“服务”中勾选“OmsKerberos”和“OmmServer”,单击“确定”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。