更新时间:2024-11-29 GMT+08:00
ALM-12001 审计日志转储失败
告警解释
根据本地历史数据备份策略,集群的审计日志需要转储到第三方服务器上。系统每天凌晨3点开始周期性检测转储服务器,如果转储服务器满足配置条件,审计日志可以成功转储。审计日志转储失败,系统产生此告警。如果第三方服务器的转储目录磁盘空间不足,或者用户修改了转储服务器的用户名、密码或转储目录,将会导致审计日志转储失败。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
12001 |
次要 |
业务质量告警 |
FusionInsight Manager |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群或系统名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
对系统的影响
系统本地最多只能保存50个转储文件,如果该故障持续存在于转储服务器,会导致本地历史审计日志丢失,查询超过当前时间点的前50条审计日志时无法查询。
可能原因
- 网络连接异常。
- 转储服务器的用户名、密码或转储目录不满足配置条件。
- 转储目录的磁盘空间不足。
处理步骤
检查网络连接是否正常。
- 在FusionInsight Manager界面,选择“审计 > 配置”,进入审计日志转储配置页面。
- 查看转储配置页面中当前的SFTP IP值是否合法有效。
- 修复网络连接,然后重新配置SFTP服务端密码,单击“确定”,重新下发一次配置。
- 2分钟后,查看告警列表中,该告警是否已清除。
- 是,处理完毕。
- 否,执行5。
检查用户名、密码和转储目录是否正确。
- 查看转储配置页面中当前的第三方服务器用户名、密码和转储目录是否正确。
- 修改用户名、密码和转储目录,单击“确定”,重新下发一次配置。
- 2分钟后,查看告警列表中,该告警是否已清除。
- 是,处理完毕。
- 否,执行8。
检查转储目录的磁盘空间是否足够。
- 根据转储配置页面中当前的转储目录,以root用户登录到第三方服务器,使用df命令检查第三方服务器的转储目录的磁盘空间是否大于100MB。
- 扩大第三方服务器的磁盘空间,然后重新配置SFTP服务端密码,单击“确定”,重新下发一次配置。
- 2分钟后,查看告警列表中,该告警是否已清除。
- 是,处理完毕。
- 否,执行11。
重新设置转储规则。
- 在FusionInsight Manager界面,选择“审计 > 配置”。
- 重新设置转储规则,填入正确的参数,单击“确定”。
- 2分钟后,查看告警列表中,该告警是否已清除。
- 是,处理完毕。
- 否,执行14。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。
父主题: 告警参考