The Client Log Contains "TCP: connect to [AF_INET] *.*.*.*:**** failed: Unknown error"
Applicable Client
- Linux
- Windows OpenVPN GUI
Symptom
A client cannot connect to a P2C VPN gateway, and the log contains the following error information:
TCP: connect to [AF_INET] *.*.*.*:**** failed: Unknown error
Possible Causes
- The client device cannot access the Internet.
- The protocol or port number in the client configuration file is different from that configured on the Server tab page of the VPN gateway.
Procedure
- Try to access other Internet services on the client device.
If the access also fails, contact your carrier to rectify the network connectivity fault.
- Log in to the Huawei Cloud management console.
- Locate the target VPN gateway, and check whether the server protocol and port are the same as those in the client configuration file.
If not, download the client configuration file again or directly modify the client configuration file, and then use the new client configuration file to reconnect the client to the VPN gateway.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot