Help Center/ Virtual Private Network/ Troubleshooting/ Client Connection Failures/ The Client Log Contains "OpenSSL Error(no start line:CERTIFICATE)"
Updated on 2024-07-23 GMT+08:00

The Client Log Contains "OpenSSL Error(no start line:CERTIFICATE)"

Symptom

A client cannot connect to a P2C VPN gateway, and the log contains the following error information:

OpenSSL: error:0480006C:PEM routines::no start line:Expecting: CERTIFICATE
OpenSSL: error:0A080009:SSL routines::PEM lib:

Possible Causes

There is no client certificate or private key in the client configuration file.

Procedure

Copy the client certificate and private key to the client configuration file, and reconnect the client to the VPN gateway.