Updated on 2024-07-23 GMT+08:00

The Client Log Contains "TLS Error"

Symptom

A client cannot connect to a P2C VPN gateway, and the log contains the following error information:

TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

Possible Causes

  • The client device cannot access the Internet.
  • The existing client configuration file is inconsistent with that on the Server tab page of the VPN gateway.

Procedure

  • Try to access other Internet services on the client device. If the access also fails, contact your carrier to rectify the network connectivity fault.
  • Log in to the Huawei Cloud console, locate the target VPN gateway, and check whether the gateway address, server port, and protocol are the same as those in the client configuration file. If not, download the client configuration file again or directly modify the client configuration file, and then use the new client configuration file to reconnect the client to the VPN gateway.