Este conteúdo foi traduzido por máquina para sua conveniência e a Huawei Cloud não pode garantir que o conteúdo foi traduzido com precisão. Para exibir o conteúdo original, use o link no canto superior direito para mudar para a página em inglês.
Central de ajuda/ Scalable File Service/ Troubleshooting/ Tempo limite de montagem de um sistema de arquivos de uso geral
Atualizado em 2026-08-24 GMT+08:00

Tempo limite de montagem de um sistema de arquivos de uso geral

Sintoma

Quando um sistema de arquivos de uso geral foi montado em um servidor em nuvem usando o comando mount, a mensagem timed out foi retornada.

Possíveis causas

  • Causa 1: a rede não está estável.
  • Causa 2: a conexão de rede está anormal.
  • Causa 3: Nenhum ponto de extremidade de VPC foi adquirido.
  • Causa 4: a configuração de DNS no servidor está incorreta. Como resultado, o nome de domínio do sistema de arquivos de uso geral não pode ser resolvido e a montagem falha.
  • Causa 5: o servidor que monta o sistema de arquivos executa o Ubuntu 18 ou posterior.

Diagnóstico de falhas

Corrija as falhas de rede e monte o sistema de arquivos novamente.

Solução

  • Causa 1 e Causa 2: a rede não está estável ou a conexão de rede está anormal.

    Remonte o sistema de arquivos após o problema de rede ser resolvido.

    • Se a remontagem for bem-sucedida, nenhuma ação adicional será necessária.
    • Se o problema persistir, consulte a solução para a Causa 3.
  • Causa 3: Nenhum ponto de extremidade de VPC foi adquirido.

    Você pode optar por adquirir um ponto de extremidade de VPC manual ou automaticamente. Para adquirir manualmente um ponto de extremidade de VPC, consulte Criação de um ponto de extremidade de VPC. Para adquirir automaticamente um ponto de extremidade de VPC, consulte Criação de um sistema de arquivos de uso geral.

    • Se a remontagem for bem-sucedida, nenhuma ação adicional será necessária.
    • Se o problema persistir, consulte a solução para a Causa 4.
  • Causa 4: a configuração de DNS no servidor está incorreta. Como resultado, o nome de domínio do sistema de arquivos de uso geral não pode ser resolvido e a montagem falha.
    1. Verifique a configuração de DNS e execute o comando cat /etc/resolv.conf.
      • Se nenhum DNS estiver configurado, configure o DNS consultando Configuração de DNS.
      • Se o DNS tiver sido configurado, execute o seguinte comando para verificar se a configuração está correta:

        nslookup <domain-name-of-the-general-purpose-file-system>

        Se o endereço IP resolvido estiver no intervalo de rede 100.x.x.x, a configuração de DNS está correta. Se o endereço IP estiver em outro intervalo de rede, a configuração de DNS está incorreta. Nesse caso, acesse 2.

    2. Modifique o arquivo de configuração do /etc/resolv.conf para configurar o DNS do locatário correto. Especificamente, execute vi /etc/resolv.conf para editar o arquivo /etc/resolv.conf. Adicione o endereço IP do servidor DNS acima das informações existentes do servidor de nomes. Para obter detalhes sobre endereços IP de servidor DNS, consulte O que são endereços de servidor DNS privado da Huawei Cloud?
      Figura 1 Configuração do DNS
      O formato é o seguinte:
      nameserver 100.125.1.250
      • Se a configuração for bem-sucedida, vá para 3.
      • Se a configuração falhar, execute o comando lsattr /etc/resolv.conf. Se as informações mostradas em Figura 2 forem exibidas, o arquivo está bloqueado.
        Figura 2 Arquivo bloqueado

        Execute chattr -i /etc/resolv.conf para desbloquear o arquivo. Em seguida, reconfigure o DNS e vá para 3.

    3. Pressione Esc, insira :wq e pressione Enter para salvar e sair.
    4. Defina o DNS do locatário correto para a sub-rede da VPC à qual o servidor pertence. Por padrão, o servidor herda a configuração de DNS da VPC toda vez que o servidor é reiniciado. Alterar apenas a configuração de DNS do servidor não resolve o problema completamente.

    5. (Opcional) Reinicie o servidor.
    6. Remonte o sistema de arquivos.
      • Se a remontagem for bem-sucedida, nenhuma ação adicional será necessária.
      • Se o problema persistir, consulte a solução para a causa 5.
  • Causa 5: o servidor que monta o sistema de arquivos executa o Ubuntu 18 ou posterior.
    1. Reconfigure o DNS consultando Configuração de um servidor DNS para resolução de nomes de domínio.
    2. Verifique se o servidor que executa o Ubuntu 18 ou posterior foi criado a partir de uma imagem privada.
      • Em caso afirmativo, vá para 4.
      • Em caso negativo, vá para 3.
    3. Converta o servidor de imagem pública em um servidor de imagem privada.
      1. Crie uma imagem privada com base no servidor de imagem pública original. Para obter detalhes, consulte Criação de uma imagem.
      2. Use a imagem privada criada em 3.a para recriar um ECS ou alterar para a imagem privada do ECS original alteração do SO.
    4. Faça login no servidor e remonte o sistema de arquivos.