Este conteúdo foi traduzido por máquina para sua conveniência e a Huawei Cloud não pode garantir que o conteúdo foi traduzido com precisão. Para exibir o conteúdo original, use o link no canto superior direito para mudar para a página em inglês.
Central de ajuda/ GaussDB(DWS)/ Guia de gerenciamento/ Monitoramento e alarmes/ Alarmes/ Tratamento de alarmes/ DWS_2000000017 Number of Queuing Query Statements Exceeds the Threshold
Atualizado em 2024-08-19 GMT+08:00

DWS_2000000017 Number of Queuing Query Statements Exceeds the Threshold

Descrição

Quando o monitoramento de consulta em tempo real está habilitado, o GaussDB(DWS) verifica o status de enfileiramento de trabalhos em CNs por meio da exibição GS_WLM_SESSION_STATISTICS a cada 60 segundos por padrão.

Este alarme é gerado quando o número de instruções SQL em enfileiramento no cluster excede 10 (configurável) em 10 minutos (configurável) e é automaticamente apagado quando o número de instruções SQL em enfileiramento cai abaixo de 10.

Se continuar a ser enfileirando instruções de consulta mais do que o limiar de alarme, o alarme é gerado novamente 24 horas depois (configurável).

Atributos do alarme

ID do alarme

Gravidade do alarme

Apagar automaticamente

DWS_2000000017

Crítico

Sim

Parâmetros do alarme

Parâmetro

Descrição

Alarm Source

Indica o nome do sistema para o qual o alarme é gerado e o tipo de alarme detalhado.

Cluster Name

ID do cluster para o qual o alarme é gerado

Location Information

ID e nome do cluster para o qual o alarme é gerado

Detail Information

CloudService indica o serviço de nuvem para o qual o alarme é gerado, incluindo o nome do serviço, ID do recurso, hora do primeiro alarme e informações de alarme formatadas. Exemplo: CloudServiceDWS, resourceId=xxxx-xxxx-xxxx-xxxx, resourceIdName=test_dws, first_alarm_time:2023-01-11:19:02:09. O número médio de instruções de consulta enfileirando no cluster test_dws em 10 minutos é 30, o que excede o limite de 10.

Generated

Hora em que um alarme é gerado.

Status

Indica o status do alarme atual.

Impacto no sistema

As consultas SQL são bloqueadas. Como resultado, o tempo de execução é muito longo.

Possíveis causas

O número de instruções de consulta de enfileiramento durante a execução do serviço excede o limite de alarme.

Procedimento de manuseio

Verifique se os trabalhos de enfileiramento atuais no cluster estão normais.

  1. Efetue logon no console do GaussDB(DWS).
  2. Na página Alarms, selecione o cluster atual na lista suspensa de seleção de cluster no canto superior direito e visualize as informações de alarme do cluster nos últimos sete dias. Localize o nome do cluster que dispara o alarme com base nas informações de localização.

  3. Na página Clusters, localize a linha que contém o cluster para o qual o alarme é gerado e clique em Monitoring Panel na coluna Operation.

  4. Escolha Monitoring > Queries para exibir as sessões e consultas em tempo real do cluster atual. Selecione a guia Queries para exibir o status dos trabalhos a serem executados no cluster atual. Clique em e selecione Blocking Time (ms) e status Waiting. Clique em para classificar os valores de Blocking Time (ms). Você pode exibir as informações sobre as instruções SQL em espera com o maior tempo de bloqueio. Se um trabalho de consulta estiver no estado de espera e o tempo de bloqueio for anormal, você poderá encerrar a consulta.

    Status atual do enfileiramento das declarações, incluindo:

    • Global: fila global.
    • Respool: enfileiramento de pool de recursos.
    • CentralQueue: enfileiramento no CCN
    • Transaction: estar em um bloco de transação
    • StoredProc: estar em um procedimento armazenado
    • None: não está na fila
    • Forced None: sendo executado forçosamente (instrução de bloco de transação ou instrução de procedimento armazenado são) porque o tempo de espera da instrução excede o valor especificado

Liberação de alarme

Este alarme é automaticamente apagado quando o número de instruções de enfileiramento fica abaixo do limite.