Help Center/ Elastic Cloud Server/ Troubleshooting/ BSOD Issues/ How Do I Troubleshoot Blue Screen or Black Screen Errors After an ECS Is Started?
Updated on 2022-07-15 GMT+08:00

How Do I Troubleshoot Blue Screen or Black Screen Errors After an ECS Is Started?

Symptom

When you are remotely logging in to an ECS, a screen that's black or blue is displayed.

Root Cause

The blue screen or black screen errors are caused by explorer.exe errors in Windows. explorer.exe is a Windows program manager or file resource manager. It is used to manage the Windows graphical shell, including desktop and file management. If this program is deleted, the Windows GUI becomes unavailable.

Solution

  1. Open the task manager of the ECS.

    On the VNC login page, click to open the task manager.

  2. On the Processes tab, check whether the explorer.exe or Windows resource manager process exists.
    • If yes, end the process.
    • If no, start the process.
      Figure 1 explorer.exe
  3. Start explorer.exe.
    Choose File > New Task. In the displayed dialog box, enter explorer.exe and click OK.

    If the dialog box is not displayed, restart the ECS.

    Figure 2 Creating a task
    Figure 3 Running explorer.exe.