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Actualización más reciente 2023-11-20 GMT+08:00

ALM-26054 El uso de memoria heap de Storm Nimbus supera el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba el uso de memoria heap de Storm Nimbus cada 30 segundos y lo compara con el umbral. Esta alarma se genera si el uso de memoria heap excede el umbral (80% de forma predeterminada).

Para modificar el umbral, los usuarios pueden elegir System > Threshold Configuration > Service > Storm en MRS Manager.

Esta alarma se borra si el uso de memoria heap es inferior o igual al umbral.

Atributo

ID de alarma

Gravedad de alarma

Borrar automáticamente

26054

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Trigger Condition

Genera una alarma cuando el valor real del indicador excede el umbral especificado.

Impacto en el sistema

Es posible que se produzca una recolección frecuente de basura de memoria o un desbordamiento de memoria, lo que afecta al envío de los servicios de Storm.

Causas posibles

El uso de la memoria heap es alto o la memoria heap está asignada incorrectamente.

Procedimiento

  1. Compruebe el uso de la memoria heap.

    1. Vaya a la página de detalles del clúster y elija Alarms.
    2. Elija ALM-26054 Heap Memory Usage of Storm Nimbus Exceeds the Threshold > Location. Consulte el HostName de la instancia con alarma.
    3. Elija Components > Storm > Instances > Nimbus (corresponding to the HostName of the alarmed instance) > Customize > Heap Memory Usage of Nimbus.
    4. Compruebe si el uso de memoria heap de Nimbus ha alcanzado el umbral (80%).
      • En caso afirmativo, vaya a 1.e.
      • Si no, vaya a 2.
    5. Ajuste la memoria heap.

      Elija Components > Storm > Service Configuration y establezca Type en All. Elija Nimbus > System. Aumente el valor de -Xmx en NIMBUS_GC_OPTS. Haga clic en Save Configuration. Seleccione Restart the affected services or instances y haga clic en OK.

    6. Verifique si la alarma se ha borrado.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

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