ALM-26053 El uso de la ranura de la Storm supera el umbral (Para MRS 2.x o anterior)
Descripción
El sistema comprueba el uso de la ranura de Storm cada 60 segundos y lo compara con el umbral. Esta alarma se genera si el uso de ranura excede el umbral.
Para modificar el umbral, los usuarios pueden elegir
en MRS Manager.Esta alarma se borra si el uso de ranura es inferior o igual al umbral.
Atributo
ID de alarma |
Gravedad de alarma |
Borrar automáticamente |
---|---|---|
26053 |
Grave |
Sí |
Parámetros
Parámetro |
Descripción |
---|---|
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Trigger condition |
Genera una alarma cuando el valor real del indicador excede el umbral especificado. |
Impacto en el sistema
Los usuarios no pueden ejecutar tareas nuevas de Storm.
Causas posibles
- Los supervisores son anormales en el clúster.
- Los supervisores son normales pero tienen una capacidad de procesamiento deficiente.
Procedimiento
- Verifique el estado del supervisor.
- Vaya a la página de detalles del clúster y haga clic en Components.
- Elija .
- En el caso de Role, compruebe si el clúster tiene instancias de supervisor que estén en estado Faulty o Recovering.
- Seleccione las instancias de supervisor que se encuentran en el estado Faulty o Recovering y elija .
- Espere un momento y compruebe si la alarma está desactivada.
- Aumentar el número de ranuras para los supervisores.
- Vaya a la página de detalles del clúster y haga clic en Components.
- Elija Storm > Supervisor > Service Configuration, y establezca Type en All.
- Aumente el valor de supervisor.slots.ports para aumentar el número de espacios para cada supervisor. A continuación, reinicie las instancias.
- Espere un momento y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 4.
- Ampliar la capacidad de los supervisores.
- Agregue nodos.
- Espere un momento y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si el reinicio falla, vaya a 4.
- Recopilar información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Información relacionada
N/A