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Actualización más reciente 2023-11-20 GMT+08:00

ALM-24003 Conexión de Flume Client interrumpida (Para MRS 2.x o anterior)

Descripción

El módulo de alarma monitorea el estado de la conexión del puerto en el Flume server. Esta alarma se genera si el Flume server no recibe un mensaje de conexión del Flume client en 3 minutos consecutivos.

Esta alarma se borra después de que el Flume server recibe un mensaje de conexión del Flume client.

Atributo

ID de alarma

Gravedad de alarma

Borrar automáticamente

24003

Grave

Parámetros

Parámetro

Descripción

ClientIP

Especifica la dirección IP del cliente de Flume.

ServerIP

Especifica la dirección IP del servidor de Flume.

ServerPort

Especifica el puerto del servidor de Flume.

Impacto en el sistema

La comunicación entre Flume client y server falla. El Flume client no puede enviar datos al Flume server.

Causas posibles

  • La red entre el Flume client y server es defectuosa.
  • El proceso del Flume client es anormal.
  • El Flume client está configurado incorrectamente.

Procedimiento

  1. Compruebe la red entre el Flume client y server.

    1. Inicie sesión en el host donde reside Flume client alarmado. Ejecute el siguiente comando para cambiar a usuario root:

      sudo su - root

    2. Ejecute el comando ping Flume server IP address para comprobar si la red entre Flume client y server es normal.
      • En caso afirmativo, vaya a 2.a.
      • Si no, vaya a 4.

  2. Compruebe si el proceso de Flume client es normal.

    1. Inicie sesión en el host donde reside Flume client alarmado. Ejecute el siguiente comando para cambiar a usuario root:

      sudo su - root

    2. Ejecute el comando ps -ef|grep flume |grep client para comprobar si existe el proceso Flume client.
      • En caso afirmativo, vaya a 3.a.
      • Si no, vaya a 4.

  3. Compruebe la configuración del Flume client.

    1. Inicie sesión en el host donde reside Flume client alarmado. Ejecute el siguiente comando para cambiar a usuario root:

      sudo su - root

    2. Ejecute el comando cd Flume installation directory/fusioninsight-flume-1.6.0/conf/ para ir al directorio de configuración de Flume.
    3. Ejecute el comando cat properties.properties para consultar el archivo de configuración actual del Flume client.
    4. Compruebe si el archivo properties.properties está configurado correctamente de acuerdo con la descripción de configuración del Flume agent.
      • En caso afirmativo, vaya a 3.e.
      • Si no, vaya a 4.
    5. Modifique el archivo de configuración properties.properties.
    6. Verifique si la alarma se ha borrado.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 4.

  4. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

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