ALM-24003 Conexión de Flume Client interrumpida (Para MRS 2.x o anterior)
Descripción
El módulo de alarma monitorea el estado de la conexión del puerto en el Flume server. Esta alarma se genera si el Flume server no recibe un mensaje de conexión del Flume client en 3 minutos consecutivos.
Esta alarma se borra después de que el Flume server recibe un mensaje de conexión del Flume client.
Atributo
ID de alarma |
Gravedad de alarma |
Borrar automáticamente |
---|---|---|
24003 |
Grave |
Sí |
Parámetros
Parámetro |
Descripción |
---|---|
ClientIP |
Especifica la dirección IP del cliente de Flume. |
ServerIP |
Especifica la dirección IP del servidor de Flume. |
ServerPort |
Especifica el puerto del servidor de Flume. |
Impacto en el sistema
La comunicación entre Flume client y server falla. El Flume client no puede enviar datos al Flume server.
Causas posibles
- La red entre el Flume client y server es defectuosa.
- El proceso del Flume client es anormal.
- El Flume client está configurado incorrectamente.
Procedimiento
- Compruebe la red entre el Flume client y server.
- Compruebe si el proceso de Flume client es normal.
- Compruebe la configuración del Flume client.
- Inicie sesión en el host donde reside Flume client alarmado. Ejecute el siguiente comando para cambiar a usuario root:
sudo su - root
- Ejecute el comando cd Flume installation directory/fusioninsight-flume-1.6.0/conf/ para ir al directorio de configuración de Flume.
- Ejecute el comando cat properties.properties para consultar el archivo de configuración actual del Flume client.
- Compruebe si el archivo properties.properties está configurado correctamente de acuerdo con la descripción de configuración del Flume agent.
- Modifique el archivo de configuración properties.properties.
- Verifique si la alarma se ha borrado.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 4.
- Inicie sesión en el host donde reside Flume client alarmado. Ejecute el siguiente comando para cambiar a usuario root:
- Recopilar información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Información relacionada
N/A