ALM-24001 El agente de Flume es anormal (Para MRS 2.x o anterior)
Descripción
Esta alarma se genera si el módulo de monitorización del agente de Flume detecta que el proceso del agente de Flume es anormal.
Esta alarma se borra después de que se recupera el proceso del agente de Flume.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
24001 |
Menor |
Sí |
Parámetros
Parámetro |
Descripción |
---|---|
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
Las funciones de la instancia de agente de Flume alarmada son anormales. Las tareas de transmisión de datos de la instancia se suspenden. En la transmisión de datos en tiempo real, los datos se perderán.
Causas posibles
- El directorio JAVA_HOME no existe o el permiso Java es incorrecto.
- El permiso del directorio del agente de Flume es incorrecto.
Procedimiento
- Compruebe el archivo de configuración del agente de Flume.
- Inicie sesión en el host donde reside el nodo defectuoso. Ejecute el siguiente comando para cambiar a usuario root:
sudo su - root
- Ejecute el comando cd Flume installation directory/fusioninsight-flume-1.6.0/conf/ para ir al directorio de configuración de Flume.
- Ejecute el comando cat ENV_VARS. Compruebe si el directorio JAVA_HOME existe y si el usuario del agente de Flume tiene permiso de ejecución de Java.
- Especifique el directorio JAVA_HOME correcto y conceda al usuario del agente de Flume el permiso de ejecución de Java. Entonces vaya a 2.d.
- Inicie sesión en el host donde reside el nodo defectuoso. Ejecute el siguiente comando para cambiar a usuario root:
- Compruebe el permiso del directorio del agente de Flume.
- Inicie sesión en el host donde reside el nodo defectuoso. Ejecute el siguiente comando para cambiar a usuario root:
sudo su - root
- Ejecute el siguiente comando para acceder al directorio de instalación del agente de Flume:
- Ejecute el comando ls -al * -R. Compruebe si el propietario de todos los archivos es el usuario del agente de Flume.
- Verifique si la alarma se ha borrado.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 3.
- Inicie sesión en el host donde reside el nodo defectuoso. Ejecute el siguiente comando para cambiar a usuario root:
- Recopilar información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Información relacionada
N/A