Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-11-20 GMT+08:00

ALM-24000 Servicio de Flume no disponible (Para MRS 2.x o anterior)

Descripción

El módulo de alarma comprueba el estado de servicio de Flume cada 180 segundos. Esta alarma se genera si el servicio Flume es anormal.

Esta alarma se borra después de que se recupere el servicio Flume.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

24000

Crítica

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impact on the System

Flume no puede funcionar y la transmisión de datos se interrumpe.

Causas posibles

  • HDFS no está disponible.
  • LdapServer no está disponible.

Procedimiento

  1. Compruebe el estado de HDFS.

    1. Vaya a la página de detalles del clúster de MRS y elija Alarms.
    2. Compruebe si se genera la alarma ALM-14000 Servicio HDFS no disponible.
      • En caso afirmativo, borre la alarma de acuerdo con las sugerencias de manejo de "ALM-14000 Servicio HDFS no disponible".
      • Si no, vaya a 2.

  2. Compruebe el estado del LdapServer.

    Compruebe si se genera la alarma ALM-25000 Servicio LdapServer no disponible.
    • En caso afirmativo, borre la alarma de acuerdo con las sugerencias de manejo de "ALM-25000 Servicio LdapServer no disponible".
    • Si no, vaya a 3.b.

  3. Compruebe si los servicios HDFS y LdapServer están detenidos.

    1. Vaya a la página de detalles del clúster MRS y haga clic en Components.
    2. En la lista de servicios en MRS Manager, compruebe si los servicios HDFS y LdapServer están detenidos.
      • En caso afirmativo, inicie los servicios HDFS y LdapServer y vaya a 3.c.
      • Si no, vaya a 4.
    3. Compruebe si la alarma "ALM-24000 Servicio Flume no disponible" está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 4.

  4. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Información relacionada

N/A